CVE-2024-2748: CSRF vulnerability was identified in GitHub Enterprise Server that allowed performing actions on behalf of a user
Noroxi assessment
Priority: Monitor (action score 17/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.18% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: GitHub Enterprise Server 3.12.1.
Low priority for now. Upgrade to GitHub Enterprise Server 3.12.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
A Cross Site Request Forgery vulnerability was identified in GitHub Enterprise Server that allowed an attacker to execute unauthorized actions on behalf of an unsuspecting user. A mitigating factor is that user interaction is required. This vulnerability affected GitHub Enterprise Server 3.12.0 and was fixed in versions 3.12.1. This vulnerability was reported via the GitHub Bug Bounty program.
- Published
- Mar 20, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.1% · 8th percentile
- CWE
- CWE-352
Report tools
Action score
17
Monitor
Low priority for now.
- CVSS
- 17 / 40 · 4.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.1%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · GitHub_P
- 4.3
- NVD has not scored this yet; the score shown is the CNA’s.
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| github | enterprise server | cpe:2.3:a:github:enterprise_server |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- github enterprise server3.12.0
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_P). Independent of NVD's CPE analysis and usually ahead of it.
GitHub Enterprise Server
- 3.12 and later · up to and including 3.12.0affected · semverfixed in 3.12.1
Same product
github: all recordsOther highest-scoring records for the same primary product.
- CVE-2024-0200Unsafe Reflection in Github Enterprise Server leading to Command Injection61This week
- CVE-2024-0507Privilege Escalation by Code Injection in the Management Console in GitHub Enterprise Server55Plan
- CVE-2026-3854Remote code execution via git push option injection in GitHub Enterprise Server46Plan
Published before and after this one in the same product
- ← EarlierCVE-2024-2443Mar 20, 2024 · Improper input validation vulnerability was identified in GitHub Enterprise Server that allowed privilege escalation in the Management Console29Monitor
- ← EarlierCVE-2024-2469Mar 20, 2024 · Remote Code Execution in GitHub Enterprise Server Allowed Administrators to gain SSH access to the appliance28Monitor
- Later →CVE-2024-1908Mar 20, 2024 · Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed Privilege Escalation26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| GitHub Enterprise Server | 3.12.1 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- adrianoapjfinder
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2024-5815118 days apartCross Site Request Forgery was identified in GitHub Enterprise Server that allowed write in a user owned repository27Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- low · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-352 · Cross-Site Request Forgery (CSRF)CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
nvd-secondary
Root cause
State-changing requests rely on the session cookie the browser sends automatically; nothing verifies that the request came from the user’s own page.
The bug in code
The whole CWE-352 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
app.use(session({ cookie: { httpOnly: true } }));
app.post("/account/address", updateAddress);Fixed
app.use(session({ cookie: { httpOnly: true, sameSite: "lax" } }));
app.post("/account/address", csrfProtection, updateAddress);Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Vendor advisories and official records. Exploit/PoC links are deliberately left out.