CVE-2023-29458: Duktape 2.6 bug crashes JavaScript putting too many values in valstack.
Noroxi assessment
Priority: Monitor (action score 30/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.75% (FIRST EPSS); higher than 54.9% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: Zabbix Zabbix 5.0.35rc1, 6.0.18rc1, 6.4.3rc1.
Low priority for now. Upgrade to Zabbix Zabbix 5.0.35rc1, 6.0.18rc1, 6.4.3rc1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Duktape is an 3rd-party embeddable JavaScript engine, with a focus on portability and compact footprint. When adding too many values in valstack JavaScript will crash. This issue occurs due to bug in Duktape 2.6 which is an 3rd-party solution that we use.
- Published
- Jul 13, 2023
- Updated
- Jun 17, 2026
- EPSS
- 0.7% · 54th percentile
- CWE
- CWE-129
Report tools
Action score
30
Monitor
Low priority for now.
- CVSS
- 30 / 40 · 7.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.7%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 7.5
- CNA · Zabbix
- 5.9
- 1.6 point gap
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:H
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| zabbix | zabbix | cpe:2.3:a:zabbix:zabbix |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- zabbix zabbix5.0.34
- zabbix zabbix6.0.17
- zabbix zabbix6.4.2
Versions reported by the vendor
Affected version ranges reported by the assigning authority (Zabbix). Independent of NVD's CPE analysis and usually ahead of it.
Zabbix Zabbix
- 5,0,0 and later · up to and including 5.0.34affected · gitfixed in 5.0.35rc1
- 6,0,0 and later · up to and including 6.0.17affected · gitfixed in 6.0.18rc1
- 6.4.0 and later · up to and including 6.4.2affected · gitfixed in 6.4.3rc1
- 7.0.0alpha1 and later · up to and including 7.0.0alpha1affected · gitfixed in 7.0.0alpha1
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:11 | zabbix | before 1:5.0.44+dfsg-1+deb11u1 | 1:5.0.44+dfsg-1+deb11u1 |
| Debian:12 | zabbix | from 0 | — |
| Debian:13 | zabbix | before 1:6.0.23+dfsg-1 | 1:6.0.23+dfsg-1 |
Same product
zabbix: all recordsOther highest-scoring records for the same primary product.
- CVE-2022-23131Unsafe client-side session storage leading to authentication bypass/instance takeover via Zabbix Frontend with configured SAMLKEV98Now
- CVE-2022-23134Possible view of the setup pages by unauthenticated users if config file already existsKEV80Now
- CVE-2016-10134SQL injection vulnerability in Zabbix before 2.2.14 and 3.0 before 3.0.4 allows remote attackers to execute arbitrary SQL commands via the t64This week
Published before and after this one in the same product
- ← EarlierCVE-2023-29451Jul 13, 2023 · Denial of service caused by a bug in the JSON parser30Monitor
- ← EarlierCVE-2023-29452Jul 13, 2023 · Remove possibility to add html into Geomap attribution field40Plan
- Later →CVE-2023-32721Oct 12, 2023 · Stored XSS in Maps element21Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Zabbix Zabbix | 5.0.35rc1 | Vendor (CNA) |
| Zabbix Zabbix | 6.0.18rc1 | Vendor (CNA) |
| Zabbix Zabbix | 6.4.3rc1 | Vendor (CNA) |
| Zabbix Zabbix | 7.0.0alpha1 | Vendor (CNA) |
| debian:zabbix | 1:6.0.23+dfsg-1 · Debian:13 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- nepalihacker0x01finder
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-129 · Improper Validation of Array IndexCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (1 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.