Skip to content
Noroxi

PowerDNS records

108 published records for vendor powerdns.

Researcher profile

Entered KEV
0 · 0%
Weaponized
0 · 0%
Pre-auth RCE
6
With a fix record
99.1%
Median publish → KEV
No record has entered KEV

All records

108 records
  • CVE-2023-50387
    60This week

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of ser

    HighCVSS 7.5Proof of conceptEPSS 99%

    redhat · enterprise linuxFeb 14, 2024

  • The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server

    HighCVSS 7.8No exploitEPSS 78%

    powerdns · authoritativeMay 18, 2015

  • The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a den

    HighCVSS 7.5Proof of conceptEPSS 74%

    netapp · hci baseboard management controllerFeb 14, 2024

  • PowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by sending a specific query (QTYPE 65535) that causes a

    HighCVSS 7.5Proof of conceptEPSS 64%

    powerdns · authoritative serverJul 30, 2021

  • PowerDNS (aka pdns) Authoritative Server before 3.4.10 does not properly handle a .

    HighCVSS 7.5No exploitEPSS 62%

    powerdns · authoritativeSep 21, 2016

  • An issue has been found in PowerDNS Recursor before version 4.1.8 where a remote attacker sending a DNS query can trigger an out-of-bounds m

    HighCVSS 7.5No exploitEPSS 58%

    powerdns · recursorDec 3, 2018

  • An issue has been found in the parsing of authoritative answers in PowerDNS Recursor before 4.0.8, leading to a NULL pointer dereference whe

    HighCVSS 7.5Proof of conceptEPSS 51%

    powerdns · recursorJul 27, 2018

  • Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute

    CriticalCVSS 10.0No exploitEPSS 17%

    powerdns · recursorJan 8, 2010

  • An issue has been found in PowerDNS Recursor 4.1.0 up to and including 4.3.0.

    HighCVSS 8.8No exploitEPSS 24%

    powerdns · recursorMay 19, 2020

  • PowerDNS Recursor before 3.6.2 does not limit delegation chaining, which allows remote attackers to cause a denial of service ("performance

    MediumCVSS 5.0No exploitEPSS 68%

    powerdns · recursorDec 10, 2014

  • PowerDNS (aka pdns) Authoritative Server 3.4.4 before 3.4.7 allows remote attackers to cause a denial of service (assertion failure and serv

    MediumCVSS 5.0No exploitEPSS 67%

    powerdns · authoritativeNov 17, 2015

  • An issue was discovered in PowerDNS Authoritative through 4.3.0 when --enable-experimental-gss-tsig is used.

    CriticalCVSS 9.8No exploitEPSS 3%

    powerdns · authoritativeOct 2, 2020

  • CVE-2016-5426
    39Monitor

    PowerDNS (aka pdns) Authoritative Server before 3.4.10 allows remote attackers to cause a denial of service (backend CPU consumption) via a

    HighCVSS 7.5No exploitEPSS 30%

    powerdns · authoritativeSep 21, 2016

  • CVE-2019-3871
    39Monitor

    A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7.

    HighCVSS 8.8No exploitEPSS 12%

    powerdns · authoritative serverMar 21, 2019

  • Incomplete domain name sanitization during

    CriticalCVSS 9.8No exploitEPSS 0%

    powerdns · authoritativeApr 22, 2026

  • CVE-2019-3807
    39Monitor

    An issue has been found in PowerDNS Recursor versions 4.1.x before 4.1.9 where records in the answer section of responses received from auth

    CriticalCVSS 9.8No exploitEPSS 0%

    powerdns · recursorJan 29, 2019

  • Out-of-bounds read in cache inspection via Lua

    CriticalCVSS 9.1No exploitEPSS 1%

    powerdns · dnsdistApr 22, 2026

  • CVE-2017-7557
    35Monitor

    dnsdist version 1.1.0 is vulnerable to a flaw in authentication mechanism for REST API potentially allowing CSRF attack.

    HighCVSS 8.8No exploitEPSS 0%

    powerdns · dnsdistAug 22, 2017

  • CVE-2015-5470
    34Monitor

    The label decompression functionality in PowerDNS Recursor before 3.6.4 and 3.7.x before 3.7.3 and Authoritative (Auth) Server before 3.3.3

    HighCVSS 7.8No exploitEPSS 11%

    powerdns · authoritativeNov 2, 2015

  • Insufficient Validation of Names During AXFR

    HighCVSS 8.6No exploitEPSS 0%

    powerdns · authoritativeMay 21, 2026

  • CVE-2009-4010
    33Monitor

    Unspecified vulnerability in PowerDNS Recursor before 3.1.7.2 allows remote attackers to spoof DNS data via crafted zones.

    HighCVSS 7.5No exploitEPSS 10%

    powerdns · recursorJan 8, 2010

  • CVE-2015-5230
    33Monitor

    The DNS packet parsing/generation code in PowerDNS (aka pdns) Authoritative Server 3.4.x before 3.4.6 allows remote attackers to cause a den

    HighCVSS 7.5No exploitEPSS 9%

    powerdns · authoritativeJan 15, 2020

  • CVE-2006-4251
    33Monitor

    Buffer overflow in PowerDNS Recursor 3.1.3 and earlier might allow remote attackers to execute arbitrary code via a malformed TCP DNS query

    HighCVSS 7.5No exploitEPSS 8%

    powerdns · recursorNov 14, 2006

  • A remote attacker might be able to cause infinite recursion in PowerDNS Recursor 4.8.0 via a DNS query that retrieves DS records for a misco

    HighCVSS 7.5No exploitEPSS 7%

    powerdns · recursorJan 21, 2023

  • CVE-2016-7068
    32Monitor

    An issue has been found in PowerDNS before 3.4.11 and 4.0.2, and PowerDNS recursor before 3.7.4 and 4.0.4, allowing a remote, unauthenticate

    HighCVSS 7.5No exploitEPSS 7%

    powerdns · authoritativeSep 11, 2018