CVE-2026-25610: Invalid $geoNear index hint may cause server crash
Noroxi assessment
Priority: Monitor (action score 28/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.27% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. A low-privileged account is enough. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: MongoDB Inc MongoDB Server 7.0.29, 8.0.13.
Low priority for now. Upgrade to MongoDB Inc MongoDB Server 7.0.29, 8.0.13 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
An authorized user may trigger a server crash by running a $geoNear pipeline with certain invalid index hints.
- Published
- Feb 10, 2026
- Updated
- Jun 17, 2026
- EPSS
- 0.2% · 20th percentile
- CWE
- CWE-617
Report tools
Action score
28
Monitor
Low priority for now.
- CVSS
- 28 / 40 · 7.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.2%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · mongodb
- 7.1
- NVD has not scored this yet; the score shown is the CNA’s.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| mongodb | mongodb | cpe:2.3:a:mongodb:mongodb |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- mongodb mongodb7.0.0 and later · before 7.0.29
- mongodb mongodb8.0.0 and later · before 8.0.13
Versions reported by the vendor
Affected version ranges reported by the assigning authority (mongodb). Independent of NVD's CPE analysis and usually ahead of it.
MongoDB Inc MongoDB Server
- 8.0 and later · before 8.0.13affected · semver
- 7.0 and later · before 7.0.29affected · semver
Same product
mongodb: all recordsOther highest-scoring records for the same primary product.
- CVE-2025-14847Zlib compressed protocol header length confusion may allow memory readKEV89Now
- CVE-2013-1892MongoDB before 2.0.9 and 2.2.x before 2.2.4 does not properly validate requests to the nativeHelper function in SpiderMonkey, which allows r40Plan
- CVE-2025-3085MongoDB Server running on Linux may allow unexpected connections where intermediate certificates are revoked39Monitor
Published before and after this one in the same product
- ← EarlierCVE-2026-1850Feb 10, 2026 · An authorized user may disable the MongoDB server by issuing a certain type of complex query due to boolean expression simplification28Monitor
- ← EarlierCVE-2026-25609Feb 10, 2026 · profile command may permit unauthorized configuration21Monitor
- Later →CVE-2026-25613Feb 10, 2026 · An unsafe cast in the MongoDB query planner can result in a segmentation fault.28Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| MongoDB Inc MongoDB Server | 7.0.29 | Vendor (CNA) |
| MongoDB Inc MongoDB Server | 8.0.13 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2026-18697182 days apartImproper Input Validation in MongoDB Aggregation Framework Allows Unauthenticated Denial of Service on mongos34Monitor
- CVE-2026-82064210 days apartUnauthenticated Denial of Service in MongoDB Server via Assertion Failure in Read Concern Processing on Replica Set Members34Monitor
- CVE-2025-1364477 days apartMongoDB may be susceptible to Invariant Failure due to batched delete28Monitor
- CVE-2026-884397 days apartCalling createIndex with certain index types can crash mongod28Monitor
- CVE-2026-9747119 days apartCrafted cross-shard merge aggregation crashes MongoDB Server28Monitor
- CVE-2026-9749119 days apartUsing MaxKey() may crash the server28Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- A low-privileged account is enough.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- Integrity
- Availability
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- X
Weakness class (CWE)
CWE-617 · Reachable AssertionCVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvd-secondary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Vendor advisories and official records. Exploit/PoC links are deliberately left out.