CVE-2026-16599: Denial of Service in GNU wget
Noroxi assessment
Priority: Monitor (action score 20/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.37% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. No account or password is required. No special conditions are required; it is repeatable.
- Fixed version: wget (openSUSE:Leap 16.0) 1.25.0-160000.4.1; wget (openSUSE:Tumbleweed) 1.25.0-7.1; wget (SUSE:Linux Enterprise Micro 5.5) 1.20.3-150000.3.40.1.
Low priority for now. Upgrade to wget (openSUSE:Leap 16.0) 1.25.0-160000.4.1; wget (openSUSE:Tumbleweed) 1.25.0-7.1; wget (SUSE:Linux Enterprise Micro 5.5) 1.20.3-150000.3.40.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
GNU wget is vulnerable to denial of service in its FTP OPIE/S-KEY authentication functionality. The server-supplied sequence number from the FTP challenge line is used as an iteration count for an MD5 key-derivation loop without any upper bound validation. A malicious FTP server or a network attacker positioned to intercept FTP traffic can send a crafted OPIE challenge with a sequence number near INT_MAX, causing wget to perform up to approximately 2.1 billion MD5 computations and suspend for some time. The --timeout option does not mitigate this because it applies only to network I/O, not CPU computation. This issue was fixed in commit e9697d98e7249b0f68a6be040a4f3dcc5bc101fa
- Published
- Aug 25, 2026
- Updated
- Aug 28, 2026
- EPSS
- 0.3% · 31th percentile
- CWE
- CWE-606
Report tools
Action score
20
Monitor
Low priority for now.
- CVSS
- 20 / 40 · 5.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.3%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · CERT-PL
- 5.1
- NVD has not scored this yet; the score shown is the CNA’s.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
—
Versions reported by the vendor
Affected version ranges reported by the assigning authority (CERT-PL). Independent of NVD's CPE analysis and usually ahead of it.
GNU wget
- up to and including 1.25.0affected · semver
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | wget | from 0 | — |
| openSUSE:Leap 16.0 | wget | before 1.25.0-160000.4.1 | 1.25.0-160000.4.1 |
| openSUSE:Tumbleweed | wget | before 1.25.0-7.1 | 1.25.0-7.1 |
| SUSE:Linux Enterprise Micro 5.5 | wget | before 1.20.3-150000.3.40.1 | 1.20.3-150000.3.40.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP7 | wget | before 1.24.5-150700.3.12.1 | 1.24.5-150700.3.12.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | wget | before 1.14-21.31.1 | 1.14-21.31.1 |
| SUSE:Linux Micro 6.0 | wget | before 1.24.5-5.1 | 1.24.5-5.1 |
| SUSE:Linux Micro 6.1 | wget | before 1.24.5-slfo.1.1_6.1 | 1.24.5-slfo.1.1_6.1 |
| SUSE:Linux Micro 6.2 | wget | before 1.25.0-160000.4.1 | 1.25.0-160000.4.1 |
Same product
gnu: all recordsOther highest-scoring records for the same primary product.
- CVE-2017-13089GNU Wget: stack overflow in HTTP protocol handling59Plan
- CVE-2016-4971GNU wget before 1.18 allows remote servers to write to arbitrary files by redirecting a request from HTTP to a crafted FTP resource.49Plan
- CVE-2014-4877Absolute path traversal vulnerability in GNU Wget before 1.16, when recursion is enabled, allows remote FTP servers to write to arbitrary fi49Plan
Published before and after this one in the same product
- ← EarlierCVE-2026-58470Jul 7, 2026 · GNU Wget 1.25.0 Integer Overflow via Content-Range Header Parsing27Monitor
- ← EarlierCVE-2026-58471Jul 7, 2026 · GNU Wget 1.25.0 Heap Buffer Overflow via convert_fname() in url.c24Monitor
- ← EarlierCVE-2026-58472Jul 7, 2026 · GNU Wget 1.25.0 Heap Buffer Overflow via HTML Attribute Encoding24Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| opensuse:wget | 1.25.0-7.1 · openSUSE:Tumbleweed | Package registry (OSV) |
| suse:wget | 1.24.5-5.1 · SUSE:Linux Micro 6.0 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- Integrity
- Availability
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- A
- Scope
- X
Weakness class (CWE)
CWE-606 · Unchecked Input for Loop ConditionCVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvd-secondary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (2 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.