CVE-2025-31121: OpenEMR allows XSS in Patient Image feature
Noroxi assessment
Priority: Monitor (action score 33/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 17.3% (FIRST EPSS); higher than 97.1% of all records.
- Anyone who can reach it over the internet can trigger it. Administrator privileges are required. Special conditions such as timing or configuration are required.
- Fixed version: openemr openemr 7.0.3.1.
Low priority for now. Upgrade to openemr openemr 7.0.3.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to 7.0.3.1, the Patient Image feature in OpenEMR is vulnerable to cross-site scripting attacks via the EXIF title in an image. This vulnerability is fixed in 7.0.3.1.
- Published
- Apr 1, 2025
- Updated
- Jun 17, 2026
- EPSS
- 17.3% · 97th percentile
- CWE
- CWE-79
Report tools
Action score
33
Monitor
Low priority for now.
- CVSS
- 28 / 40 · 7.0 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 5 / 30 · 17.3%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- no
- Technical impact
- total
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · GitHub_M
- 7.0
- NVD has not scored this yet; the score shown is the CNA’s.
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| open-emr | openemr | cpe:2.3:a:open-emr:openemr |
Limit the impact of XSS
This is a cross-site scripting (XSS) vulnerability. A well-configured Content-Security-Policy doesn't fix it, but greatly reduces its impact. Check your site's CSP and other security headers for free.
Check security headersAffected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- open-emr openemrbefore 7.0.3.1
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
openemr openemr
- < 7.0.3.1affected
Same product
open-emr: all recordsOther highest-scoring records for the same primary product.
- CVE-2018-17179An issue was discovered in OpenEMR before 5.0.1 Patch 7.60This week
- CVE-2020-19364OpenEMR 5.0.1 allows an authenticated attacker to upload and execute malicious PHP scripts through /controller.php.56Plan
- CVE-2019-14530An issue was discovered in custom/ajax_download.php in OpenEMR before 5.0.2 via the fileName parameter.55Plan
Published before and after this one in the same product
- ← EarlierCVE-2025-30161Mar 31, 2025 · OpenEMR Stored XSS in OpenEMR Bronchitis Form36Monitor
- ← EarlierCVE-2025-31117Mar 31, 2025 · OpenEMR Out-of-Band Server-Side Request Forgery (OOB SSRF) Vulnerability27Monitor
- Later →CVE-2024-22611Apr 3, 2025 · OpenEMR 7.0.2 is vulnerable to SQL Injection via \openemr\library\classes\Pharmacy.class.php, \controllers\C_Pharmacy.class.php and \openemr41Plan
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| openemr openemr | 7.0.3.1 · description | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2026-32118344 days apartOpenEMR has Stored XSS in Graphical Pain Map legend via unescaped annotation text36Monitor
- CVE-2025-4386052 days apartOpemEMR Vulnerable to Stored XSS Attack in the Additional Address Section of Patient Demographics35Monitor
- CVE-2025-67491329 days apartOpenEMR has Stored XSS in ub04 helper34Monitor
- CVE-2026-33299352 days apartOpenEMR has Stored XSS in patient encounter Eye Exam form answers34Monitor
- CVE-2026-33346352 days apartOpenEMR has stored XSS in portal_payment.php via Unescaped table_args34Monitor
- CVE-2026-46518434 days apartOpenEMR: Stored XSS in prescription CSS/HTML print view via patient demographics34Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- Administrator privileges are required.
- Special conditions such as timing or configuration are required.
If successful
- Confidentiality
- Integrity
- Availability
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- High
- User interaction
- A
- Scope
- X
Weakness class (CWE)
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVSS vector
CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvd-secondary
Root cause
User content is inserted into the page as HTML. The browser interprets the content as code rather than data.
The bug in code
The whole CWE-79 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
commentEl.innerHTML = comment.body;Fixed
commentEl.textContent = comment.body;Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →