CVE-2025-24031: PAM-PKCS#11 vulnerable to segmentation fault on ctrl-c/ctrl-d when asked for PIN
Noroxi assessment
Priority: Monitor (action score 20/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.14% (FIRST EPSS).
- Someone with local access to the system can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: pam_pkcs11 (openSUSE:Leap 15.6) 0.6.10-150600.16.3.1; pam_pkcs11 (SUSE:Linux Enterprise Micro 5.3) 0.6.10-150100.3.6.1; pam_pkcs11 (SUSE:Linux Enterprise Module for Basesystem 15 SP6) 0.6.10-150600.16.3.1.
Low priority for now. Upgrade to pam_pkcs11 (openSUSE:Leap 15.6) 0.6.10-150600.16.3.1; pam_pkcs11 (SUSE:Linux Enterprise Micro 5.3) 0.6.10-150100.3.6.1; pam_pkcs11 (SUSE:Linux Enterprise Module for Basesystem 15 SP6) 0.6.10-150600.16.3.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
PAM-PKCS#11 is a Linux-PAM login module that allows a X.509 certificate based user login. In versions 0.6.12 and prior, the pam_pkcs11 module segfaults when a user presses ctrl-c/ctrl-d when they are asked for a PIN. When a user enters no PIN at all, `pam_get_pwd` will never initialize the password buffer pointer and as such `cleanse` will try to dereference an uninitialized pointer. On my system this pointer happens to have the value 3 most of the time when running sudo and as such it will segfault. The most likely impact to a system affected by this issue is an availability impact due to a daemon that uses PAM crashing. As of time of publication, a patch for the issue is unavailable.
- Published
- Feb 10, 2025
- Updated
- Jun 17, 2026
- EPSS
- 0.1% · 3th percentile
- CWE
- CWE-476
Report tools
Action score
20
Monitor
Low priority for now.
- CVSS
- 20 / 40 · 5.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.1%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · GitHub_M
- 5.1
- NVD has not scored this yet; the score shown is the CNA’s.
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:L
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
—
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
OpenSC pam_pkcs11
- <= 0.6.12affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | pam-pkcs11 | from 0 | — |
| openSUSE:Leap 15.6 | pam_pkcs11 | before 0.6.10-150600.16.3.1 | 0.6.10-150600.16.3.1 |
| SUSE:Linux Enterprise Micro 5.3 | pam_pkcs11 | before 0.6.10-150100.3.6.1 | 0.6.10-150100.3.6.1 |
| SUSE:Linux Enterprise Module for Basesystem 15 SP6 | pam_pkcs11 | before 0.6.10-150600.16.3.1 | 0.6.10-150600.16.3.1 |
| SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | pam_pkcs11 | before 0.6.8-7.8.1 | 0.6.8-7.8.1 |
| SUSE:Linux Micro 6.0 | pam_pkcs11 | before 0.6.12-3.1 | 0.6.12-3.1 |
Same product
opensc: all recordsOther highest-scoring records for the same primary product.
- CVE-2025-24032PAM-PKCS#11 vulnerable to authentication bypass with default value for `cert_policy` (`none`)36Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| opensuse:pam_pkcs11 | 0.6.10-150600.16.3.1 · openSUSE:Leap 15.6 | Package registry (OSV) |
| suse:pam_pkcs11 | 0.6.10-150600.16.3.1 · SUSE:Linux Enterprise Module for Basesystem 15 SP6 | Package registry (OSV) |
| suse:pam_pkcs11 | 0.6.8-7.8.1 · SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- Integrity
- Availability
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- X
Weakness class (CWE)
CWE-476 · NULL Pointer DereferenceCVSS vector
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvd-secondary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (2 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.