CVE-2024-8617: Quiz Maker <= 6.5.9.8 - Admin+ Stored XSS
Noroxi assessment
Priority: Monitor (action score 19/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.32% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. Administrator privileges are required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: Unknown Quiz Maker 6.5.9.9.
Low priority for now. Upgrade to Unknown Quiz Maker 6.5.9.9 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The Quiz Maker WordPress plugin before 6.5.9.9 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
- Published
- May 15, 2025
- Updated
- Jun 17, 2026
- EPSS
- 0.3% · 25th percentile
- CWE
- CWE-79
Report tools
Action score
19
Monitor
Low priority for now.
- CVSS
- 19 / 40 · 4.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.3%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
Is Quiz Maker by AYS on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| ays-pro | quiz maker | cpe:2.3:a:ays-pro:quiz_maker |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- ays-pro quiz makerbefore 6.5.9.9
Versions reported by the vendor
Affected version ranges reported by the assigning authority (WPScan). Independent of NVD's CPE analysis and usually ahead of it.
Unknown Quiz Maker
- before 6.5.9.9affected · semver
Same product
ays-pro: all recordsOther highest-scoring records for the same primary product.
- CVE-2024-6028Quiz Maker <= 6.5.8.3 - Unauthenticated SQL Injection via 'ays_questions' Parameter43Plan
- CVE-2025-30774WordPress Quiz Maker plugin <= 6.6.8.7 - SQL Injection vulnerability39Monitor
- CVE-2025-12426Quiz Maker <= 6.7.0.80 - Unauthenticated Sensitive Information Exposure30Monitor
Published before and after this one in the same product
- ← EarlierCVE-2023-23985Apr 24, 2024 · WordPress Quiz Maker plugin <= 6.3.9.4 - Content Spoofing21Monitor
- ← EarlierCVE-2024-10628Jan 26, 2025 · Quiz Maker Business, Developer, and Agency <= (Multiple Versions) - Unauthenticated SQL Injection via id30Monitor
- Later →CVE-2025-10042Sep 17, 2025 · Quiz Maker <= 6.7.0.56 - Unauthenticated SQL Injection30Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Unknown Quiz Maker | 6.5.9.9 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- WPScancoordinator
- Krugov ArtyomPatchstack Bug Bounty Programfinder
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2026-2384280 days apartQuiz Maker <= 6.7.1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode25Monitor
- CVE-2023-6166506 days apartQuiz Maker < 6.4.9.5 - Reflected Cross-Site Scripting24Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- Administrator privileges are required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
Impact can extend beyond the vulnerable component (scope changes).
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- Required
- Scope
- Changed
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
nvd-secondary
Root cause
User content is inserted into the page as HTML. The browser interprets the content as code rather than data.
The bug in code
The whole CWE-79 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
commentEl.innerHTML = comment.body;Fixed
commentEl.textContent = comment.body;Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →