CVE-2024-56045: WordPress WPLMS plugin < 1.9.9.5 - Unauthenticated Arbitrary Directory Deletion vulnerability
Noroxi assessment
Priority: Monitor (action score 37/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.70% (FIRST EPSS); higher than 53.3% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- According to CISA the attack is automatable: targets can be found by mass scanning.
- Fixed version: VibeThemes WPLMS 1.9.9.5.
Low priority for now. Upgrade to VibeThemes WPLMS 1.9.9.5 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Path Traversal: '.../...//' vulnerability in VibeThemes WPLMS wplms_plugin allows Path Traversal.This issue affects WPLMS: from n/a through < 1.9.9.5.
- Published
- Dec 31, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.7% · 53th percentile
- CWE
- CWE-35
Report tools
Action score
37
Monitor
Low priority for now.
- CVSS
- 37 / 40 · 9.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.7%
CISA SSVC decision
- Exploitation
- none
- Automatable
- yes
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · Patchstack
- 9.3
- NVD has not scored this yet; the score shown is the CNA’s.
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Is WPLMS on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| vibethemes | wordpress learning management system | cpe:2.3:a:vibethemes:wordpress_learning_management_system |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- vibethemes wordpress learning management systembefore 1.9.9.5
Versions reported by the vendor
Affected version ranges reported by the assigning authority (Patchstack). Independent of NVD's CPE analysis and usually ahead of it.
VibeThemes WPLMS
- up to and including 1.9.9.5affectedfixed in 1.9.9.5
Same product
vibethemes: all recordsOther highest-scoring records for the same primary product.
- CVE-2024-10470WPLMS Learning Management System for WordPress <= 4.962 - Unauthenticated Arbitrary File Read and Deletion49Plan
- CVE-2025-58668WordPress WPLMS theme <= 4.970 - Broken Access Control vulnerability39Monitor
- CVE-2024-56044WordPress WPLMS plugin <= 1.9.9 - Unauthenticated Arbitrary User Token Generation vulnerability39Monitor
Published before and after this one in the same product
- ← EarlierCVE-2024-56046Dec 31, 2024 · WordPress WPLMS plugin <= 1.9.9 - Unauthenticated Arbitrary File Upload vulnerability39Monitor
- ← EarlierCVE-2024-56043Dec 31, 2024 · WordPress WPLMS plugin <= 1.9.9 - Unauthenticated Privilege Escalation vulnerability39Monitor
- Later →CVE-2025-49925Oct 22, 2025 · WordPress WPLMS plugin <= 1.9.9.7 - Broken Access Control vulnerability30Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| VibeThemes WPLMS | 1.9.9.5 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- Rafie MuhammadPatchstackfinder
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2024-5605513 days apartWordPress WPLMS plugin < 1.9.9.5.2 - Arbitrary Directory Deletion vulnerability35Monitor
- CVE-2024-5604913 days apartWordPress WPLMS plugin < 1.9.9.5.2 - Subscriber+ Arbitrary File Deletion vulnerability34Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- low · data or configuration can be modified
- Availability
- high · the service can be disrupted
Impact can extend beyond the vulnerable component (scope changes).
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Changed
- Confidentiality impact
- None
- Integrity impact
- Low
- Availability impact
- High
Weakness class (CWE)
CWE-35 · Path Traversal: '.../...//'CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:H
nvd-secondary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Vendor advisories and official records. Exploit/PoC links are deliberately left out.