CVE-2024-5333: The Events Calendar < 6.8.2.1 - Unauthenticated Password Protected Event Disclosure
Noroxi assessment
Priority: Monitor (action score 21/100)
- A ready-made attack module is public (Nuclei); exploiting it takes no special expertise.
- Public proof-of-concept code exists (Exploit-DB / GitHub); there is no record of exploitation in the wild.
- Probability of exploitation in the next 30 days: 1.1% (FIRST EPSS); higher than 66.2% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- According to CISA the attack is automatable: targets can be found by mass scanning.
- Fixed version: Unknown The Events Calendar 6.8.2.1.
Low priority for now. Upgrade to Unknown The Events Calendar 6.8.2.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The Events Calendar WordPress plugin before 6.8.2.1 is missing access checks in the REST API, allowing for unauthenticated users to access information about password protected events.
- Published
- Dec 16, 2024
- Updated
- Jun 17, 2026
- EPSS
- 1.1% · 66th percentile
- CWE
- CWE-639
Report tools
Action score
21
Monitor
Low priority for now.
- CVSS
- 21 / 40 · 5.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 1.1%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- yes
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
Is The Events Calendar on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| stellarwp | the events calendar | cpe:2.3:a:stellarwp:the_events_calendar |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- stellarwp the events calendarbefore 6.8.2.1
Versions reported by the vendor
Affected version ranges reported by the assigning authority (WPScan). Independent of NVD's CPE analysis and usually ahead of it.
Unknown The Events Calendar
- before 6.8.2.1affected · semver
Same product
stellarwp: all recordsOther highest-scoring records for the same primary product.
- CVE-2024-8275The Events Calendar <= 6.6.4 - Unauthenticated SQL Injection54Plan
- CVE-2026-78159The Events Calendar <= 6.17.3 - Unauthenticated Code Injection to Remote Code Execution via Widget 'classes' Map Callable Invocation39Monitor
- CVE-2026-78006The Events Calendar <= 6.17.4 - Unauthenticated PHP Object Injection to Remote Code Execution39Monitor
Published before and after this one in the same product
- ← EarlierCVE-2024-4180Jun 4, 2024 · The Events Calendar < 6.4.0.1 - Reflected XSS37Monitor
- ← EarlierCVE-2024-6931Sep 27, 2024 · The Events Calendar <= 6.6.3 - Unauthenticated Stored Cross-Site Scripting29Monitor
- Later →CVE-2024-37518Jan 2, 2025 · WordPress The Events Calendar plugin <= 6.5.1.4 - Cross Site Request Forgery (CSRF) vulnerability17Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Unknown The Events Calendar | 6.8.2.1 | Vendor (CNA) |
Exploit status
Proof of concept available
A public proof of concept or detection signature exists. Exploit knowledge is out there; don't delay patching.
Evidence
- Nuclei detection template ×1
Noroxi does not host or link to exploit code. Metasploit module names and Nuclei template ids are shown (names, not code); Exploit-DB entries and PoC repositories are given as counts only.
| Source | Kind | Date |
|---|---|---|
| Nuclei detection template | Nuclei template CVE-2024-5333 | — |
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- Felipe Caonfinder
- WPScancoordinator
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- none
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- Low
- Integrity impact
- None
- Availability impact
- None
Weakness class (CWE)
CWE-639 · Authorization Bypass Through User-Controlled KeyCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
nvd-secondary
Root cause
The endpoint fetches the record by the ID sent in the request, but never checks whether the record belongs to the requesting user.
The bug in code
The whole CWE-639 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
const invoice = await Invoice.findById(req.params.id);
res.json(invoice);Fixed
const invoice = await Invoice.findOne({
id: req.params.id,
ownerId: req.user.id,
});
if (!invoice) return res.sendStatus(404);
res.json(invoice);Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →