CVE-2024-47616: Pomerium's service account access token may grant unintended access to databroker API
Noroxi assessment
Priority: Monitor (action score 27/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.57% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. A low-privileged account is enough. No user action is required. Special conditions such as timing or configuration are required.
- Fixed version: pomerium pomerium 0.27.1.
Low priority for now. Upgrade to pomerium pomerium 0.27.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Pomerium is an identity and context-aware access proxy. The Pomerium databroker service is responsible for managing all persistent Pomerium application state. Requests to the databroker service API are authorized by the presence of a JSON Web Token (JWT) signed by a key known by all Pomerium services in the same deployment. However, incomplete validation of this JWT meant that some service account access tokens would incorrectly be treated as valid for the purpose of databroker API authorization. Improper access to the databroker API could allow exfiltration of user info, spoofing of user sessions, or tampering with Pomerium routes, policies, and other settings. A Pomerium deployment is susceptible to this issue if all of the following conditions are met, you have issued a service account access token using Pomerium Zero or Pomerium Enterprise, the access token has an explicit expiration date in the future, and the core Pomerium databroker gRPC API is not otherwise secured by network access controls. This vulnerability is fixed in 0.27.1.
- Published
- Oct 2, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.5% · 47th percentile
- CWE
- CWE-863
Report tools
Action score
27
Monitor
Low priority for now.
- CVSS
- 27 / 40 · 6.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.5%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- —
- CNA · GitHub_M
- 6.8
- NVD has not scored this yet; the score shown is the CNA’s.
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
—
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
pomerium pomerium
- < 0.27.1affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Go | github.com/pomerium/pomerium | before 0.27.1 | 0.27.1 |
| openSUSE:Leap 15.5 | govulncheck-vulndb | before 0.0.20241030T212825-150000.1.9.1 | 0.0.20241030T212825-150000.1.9.1 |
| openSUSE:Tumbleweed | govulncheck-vulndb | before 0.0.20241030T212825-1.1 | 0.0.20241030T212825-1.1 |
| SUSE:Linux Enterprise Module for Package Hub 15 SP5 | govulncheck-vulndb | before 0.0.20241030T212825-150000.1.9.1 | 0.0.20241030T212825-150000.1.9.1 |
Same product
pomerium: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-33189Incorrect Authorization with specially crafted requests39Monitor
- CVE-2022-24797Exposure of Sensitive Information in Pomerium36Monitor
- CVE-2021-41230OIDC claims not updated from Identity Provider in Pomerium35Monitor
Published before and after this one in the same product
- ← EarlierCVE-2021-39206Sep 9, 2021 · Incorrect Authorization with specially crafted requests34Monitor
- ← EarlierCVE-2024-39315Jul 2, 2024 · Pomerium exposed OAuth2 access and ID tokens in user info endpoint response26Monitor
- Later →CVE-2026-50285Sep 17, 2026 · Pomerium: Pre-Auth Memory Exhaustion via Unbounded zstd Decompression in HPKE Callback30Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| pomerium pomerium | 0.27.1 · description | Vendor (CNA) |
| Go:github.com/pomerium/pomerium | 0.27.1 | Package registry (OSV) |
| opensuse:govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 · openSUSE:Leap 15.5 | Package registry (OSV) |
| suse:govulncheck-vulndb | 0.0.20241030T212825-150000.1.9.1 · SUSE:Linux Enterprise Module for Package Hub 15 SP5 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- A low-privileged account is enough.
- No user action is required.
- Special conditions such as timing or configuration are required.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- None
Weakness class (CWE)
CWE-863 · Incorrect AuthorizationCVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
nvd-secondary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (2 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.