CVE-2024-32812: WordPress Podlove Podcast Publisher plugin <= 4.0.11 - Server Side Request Forgery (SSRF) vulnerability
Noroxi assessment
Priority: Monitor (action score 21/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.38% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. A low-privileged account is enough. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: Podlove Podlove Podcast Publisher 4.0.12.
Low priority for now. Upgrade to Podlove Podlove Podcast Publisher 4.0.12 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Server-Side Request Forgery (SSRF) vulnerability in Podlove Podlove Podcast Publisher.This issue affects Podlove Podcast Publisher: from n/a through 4.0.11.
- Published
- Apr 24, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.3% · 31th percentile
- CWE
- CWE-918
Report tools
Action score
21
Monitor
Low priority for now.
- CVSS
- 21 / 40 · 5.4 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.3%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 5.4
- CNA · Patchstack
- 5.4
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Is Podlove Podcast Publisher on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| podlove | podlove podcast publisher | cpe:2.3:a:podlove:podlove_podcast_publisher |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- podlove podlove podcast publisherbefore 4.0.12
Versions reported by the vendor
Affected version ranges reported by the assigning authority (Patchstack). Independent of NVD's CPE analysis and usually ahead of it.
Podlove Podlove Podcast Publisher
- n/a and later · up to and including 4.0.11affectedfixed in 4.0.12
Same product
podlove: all recordsOther highest-scoring records for the same primary product.
- CVE-2021-24666Podlove Podcast Publisher < 3.5.6 - Unauthenticated SQL Injection42Plan
- CVE-2016-10942The podlove-podcasting-plugin-for-wordpress plugin before 2.3.16 for WordPress has SQL injection via the insert_id parameter exploitable via40Plan
- CVE-2024-43984WordPress Podlove Podcast Publisher plugin <= 4.1.13 - CSRF to Remote Code Execution (RCE) vulnerability35Monitor
Published before and after this one in the same product
- ← EarlierCVE-2024-29915Mar 27, 2024 · WordPress Podlove Podcast Publisher plugin <= 4.0.9 - Reflected Cross Site Scripting (XSS) vulnerability24Monitor
- ← EarlierCVE-2024-32139Apr 15, 2024 · WordPress Podlove Podcast Publisher plugin <= 4.0.12 - SQL Injection vulnerability35Monitor
- Later →CVE-2024-32712May 14, 2024 · WordPress Podlove Podcast Publisher plugin <= 4.0.14 - Broken Access Control vulnerability17Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Podlove Podlove Podcast Publisher | 4.0.12 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- A low-privileged account is enough.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-918 · Server-Side Request Forgery (SSRF)CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Vendor advisories and official records. Exploit/PoC links are deliberately left out.