CVE-2024-10396: Fileserver crash and possible information leak on StoreACL/FetchACL
Noroxi assessment
Priority: Monitor (action score 26/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.55% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. A low-privileged account is enough. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: The OpenAFS Foundation OpenAFS 1.6.24, 1.8.12.2, 1.9.1.
Low priority for now. Upgrade to The OpenAFS Foundation OpenAFS 1.6.24, 1.8.12.2, 1.9.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
An authenticated user can provide a malformed ACL to the fileserver's StoreACL RPC, causing the fileserver to crash, possibly expose uninitialized memory, and possibly store garbage data in the audit log. Malformed ACLs provided in responses to client FetchACL RPCs can cause client processes to crash and possibly expose uninitialized memory into other ACLs stored on the server.
- Published
- Nov 14, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.5% · 46th percentile
- CWE
- CWE-772
Report tools
Action score
26
Monitor
Low priority for now.
- CVSS
- 26 / 40 · 6.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.5%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 6.5
- CNA · fedora
- 6.5
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| openafs | openafs | cpe:2.3:a:openafs:openafs |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- openafs openafs1.0 and later · before 1.6.25
- openafs openafs1.8.0 and later · before 1.8.13
- openafs openafs1.9.0
Versions reported by the vendor
Affected version ranges reported by the assigning authority (fedora). Independent of NVD's CPE analysis and usually ahead of it.
The OpenAFS Foundation OpenAFS
- 1.0 and later · before 1.6.24affected · semver
- 1.8.0 and later · before 1.8.12.2affected · semver
- 1.9.0 and later · before 1.9.1affected · semver
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:11 | openafs | before 1.8.6-5+deb11u1 | 1.8.6-5+deb11u1 |
| Debian:12 | openafs | before 1.8.9-1+deb12u1 | 1.8.9-1+deb12u1 |
| Debian:13 | openafs | before 1.8.13-1 | 1.8.13-1 |
Same product
openafs: all recordsOther highest-scoring records for the same primary product.
- CVE-2018-16947An issue was discovered in OpenAFS before 1.6.23 and 1.8.x before 1.8.2.40Plan
- CVE-2024-10394Theft of credentials in Unix client PAGs33Monitor
- CVE-2018-16949An issue was discovered in OpenAFS before 1.6.23 and 1.8.x before 1.8.2.31Monitor
Published before and after this one in the same product
- ← EarlierCVE-2019-18602Oct 29, 2019 · OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over30Monitor
- ← EarlierCVE-2019-18603Oct 29, 2019 · OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to information leakage upon certain error conditions because uninitialized RPC output 23Monitor
- Later →CVE-2024-10397Nov 14, 2024 · Preallocated buffer overflows in XDR responses30Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| The OpenAFS Foundation OpenAFS | 1.6.24 | Vendor (CNA) |
| The OpenAFS Foundation OpenAFS | 1.8.12.2 | Vendor (CNA) |
| The OpenAFS Foundation OpenAFS | 1.9.1 | Vendor (CNA) |
| debian:openafs | 1.8.9-1+deb12u1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- A low-privileged account is enough.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-772 · Missing Release of Resource after Effective LifetimeCVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (2 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.