CVE-2023-7080: Arbitrary remote code execution within wrangler dev Workers sandbox
Noroxi assessment
Priority: Monitor (action score 32/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.63% (FIRST EPSS); higher than 50% of all records.
- Someone on the same network segment can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: Cloudflare wrangler 2.20.2, 3.19.0.
Low priority for now. Upgrade to Cloudflare wrangler 2.20.2, 3.19.0 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The V8 inspector intentionally allows arbitrary code execution within the Workers sandbox for debugging. wrangler dev would previously start an inspector server listening on all network interfaces. This would allow an attacker on the local network to connect to the inspector and run arbitrary code. Additionally, the inspector server did not validate Origin/Host headers, granting an attacker that can trick any user on the local network into opening a malicious website the ability to run code. If wrangler dev --remote was being used, an attacker could access production resources if they were bound to the worker. This issue was fixed in wrangler@3.19.0 and wrangler@2.20.2. Whilst wrangler dev's inspector server listens on local interfaces by default as of wrangler@3.16.0, an SSRF vulnerability in miniflare https://github.com/cloudflare/workers-sdk/security/advisories/GHSA-fwvg-2739-22v7 (CVE-2023-7078) allowed access from the local network until wrangler@3.18.0. wrangler@3.19.0 and wrangler@2.20.2 introduced validation for the Origin/Host headers.
- Published
- Dec 29, 2023
- Updated
- Jun 17, 2026
- EPSS
- 0.6% · 50th percentile
- CWE
- CWE-269
Report tools
Action score
32
Monitor
Low priority for now.
- CVSS
- 32 / 40 · 8.0 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.6%
CNA vs NVD score
- NVD
- 8.0
- CNA · cloudflare
- 8.5
- 0.5 point gap
CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| cloudflare | wrangler | cpe:2.3:a:cloudflare:wrangler |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- cloudflare wrangler2.0.0 and later · before 2.20.2
- cloudflare wrangler3.0.0 and later · before 3.19.0
Versions reported by the vendor
Affected version ranges reported by the assigning authority (cloudflare). Independent of NVD's CPE analysis and usually ahead of it.
Cloudflare wrangler
- up to and including 3.0.0affected · patchfixed in 3.19.0
- before 3.19.0affected · patchfixed in 3.19.0
- up to and including 2.0.0affected · patchfixed in 2.20.2
- before 2.20.2affected · patchfixed in 2.20.2
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| npm | wrangler | from 2.0.0 · before 2.20.2 | 2.20.2 |
| npm | wrangler | from 3.0.0 · before 3.19.0 | 3.19.0 |
Same product
cloudflare: all recordsOther highest-scoring records for the same primary product.
- CVE-2026-0933OS Command Injection in `wrangler pages deploy`30Monitor
- CVE-2023-7079Arbitrary remote file read in Wrangler dev server22Monitor
- CVE-2023-3348Directory traversal vulnerability in Cloudflare Wrangler22Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Cloudflare wrangler | 2.20.2 | Vendor (CNA) |
| Cloudflare wrangler | 3.19.0 | Vendor (CNA) |
| npm:wrangler | 2.20.2 | Package registry (OSV) |
| npm:wrangler | 3.19.0 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- Peter Wu (Lekensteyn)reporter
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Someone on the same network segment can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Adjacent
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-269 · Improper Privilege ManagementCVSS vector
CVSS:3.1/AV:A/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
nvd-primary
Root cause
To simplify setup, a service account is granted broad, cluster-wide permissions. The principle of least privilege is skipped during installation.
The bug in code
The whole CWE-269 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
kind: ClusterRole
rules:
- apiGroups: ["*"]
resources: ["*"]
verbs: ["*"]Fixed
kind: Role
metadata:
namespace: lodos-system
rules:
- apiGroups: ["apps"]
resources: ["deployments"]
verbs: ["get", "list", "update"]Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (4 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.