CVE-2023-5958: POST SMTP Mailer < 2.7.1 - Unauthenticated Cross-site Scripting
Noroxi assessment
Priority: Monitor (action score 24/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.51% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: Unknown POST SMTP Mailer 2.7.1.
Low priority for now. Upgrade to Unknown POST SMTP Mailer 2.7.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The POST SMTP Mailer WordPress plugin before 2.7.1 does not escape email message content before displaying it in the backend, allowing an unauthenticated attacker to perform XSS attacks against highly privileged users.
- Published
- Nov 27, 2023
- Updated
- Jun 17, 2026
- EPSS
- 0.5% · 43th percentile
- CWE
- CWE-79
Report tools
Action score
24
Monitor
Low priority for now.
- CVSS
- 24 / 40 · 6.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.5%
Is Post SMTP – Complete Email Delivery and SMTP Solution with Email Logs, Alerts, Backup SMTP & Mobile App on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| wpexperts | post smtp | cpe:2.3:a:wpexperts:post_smtp |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- wpexperts post smtpbefore 2.7.1
Versions reported by the vendor
Affected version ranges reported by the assigning authority (WPScan). Independent of NVD's CPE analysis and usually ahead of it.
Unknown POST SMTP Mailer
- before 2.7.1affected · semver
Same product
wpexperts: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-6875POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.8.7 - Authorization Bypass via type connect-app API66This week
- CVE-2023-52233WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability39Monitor
- CVE-2025-22800WordPress Post SMTP plugin <= 2.9.11 - Broken Access Control vulnerability35Monitor
Published before and after this one in the same product
- ← EarlierCVE-2021-4422Jul 12, 2023 · POST SMTP Mailer <= 2.0.20 - Cross-Site Request Forgery Bypass17Monitor
- ← EarlierCVE-2023-3179Jul 17, 2023 · POST SMTP Mailer < 2.5.7 - Account Takeover via CSRF35Monitor
- Later →CVE-2023-6629Jan 3, 2024 · POST SMTP Mailer <= 2.8.6 - Reflected Cross-Site Scripting via msg24Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Unknown POST SMTP Mailer | 2.7.1 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- WPScancoordinator
- Marcin Węgłowski (AFINE Team)finder
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2023-662137 days apartPost SMTP < 2.8.7 - Reflected Cross-Site Scripting24Monitor
- CVE-2023-662937 days apartPOST SMTP Mailer <= 2.8.6 - Reflected Cross-Site Scripting via msg24Monitor
- CVE-2024-29128113 days apartWordPress POST SMTP Mailer plugin <= 2.8.6 - Reflected Cross Site Scripting (XSS) vulnerability24Monitor
- CVE-2023-3082138 days apartPost SMTP <= 2.5.7 - Unauthenticated Stored Cross-Site Scripting via Email24Monitor
- CVE-2025-0521449 days apartPost SMTP <= 3.0.2 - Unauthenticated Stored Cross-Site Scripting24Monitor
- CVE-2023-702737 days apartPOST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress <= 2.8.7 - Unauthenticated Stored Cross-Site Scripting via device21Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
Impact can extend beyond the vulnerable component (scope changes).
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Changed
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
nvd-primary
Root cause
User content is inserted into the page as HTML. The browser interprets the content as code rather than data.
The bug in code
The whole CWE-79 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
commentEl.innerHTML = comment.body;Fixed
commentEl.textContent = comment.body;Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →