CVE-2023-5955: Contact Form Email < 1.3.44 - Editor+ Stored Cross-Site Scripting
Noroxi assessment
Priority: Monitor (action score 19/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.45% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. Administrator privileges are required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: Unknown Contact Form Email 1.3.44.
Low priority for now. Upgrade to Unknown Contact Form Email 1.3.44 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The Contact Form Email WordPress plugin before 1.3.44 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
- Published
- Dec 11, 2023
- Updated
- Jun 17, 2026
- EPSS
- 0.4% · 39th percentile
- CWE
- CWE-79
Report tools
Action score
19
Monitor
Low priority for now.
- CVSS
- 19 / 40 · 4.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.4%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
Is Contact Form Email on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| codepeople | contact form email | cpe:2.3:a:codepeople:contact_form_email |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- codepeople contact form emailbefore 1.3.44
Versions reported by the vendor
Affected version ranges reported by the assigning authority (WPScan). Independent of NVD's CPE analysis and usually ahead of it.
Unknown Contact Form Email
- before 1.3.44affected · semver
Same product
codepeople: all recordsOther highest-scoring records for the same primary product.
- CVE-2018-20964The contact-form-to-email plugin before 1.2.66 for WordPress has CSRF.35Monitor
- CVE-2026-112379WordPress Contact Form Email plugin <= 1.3.68 - Cross Site Scripting (XSS) vulnerability28Monitor
- CVE-2026-32483WordPress Contact Form Email plugin <= 1.3.63 - Broken Access Control vulnerability26Monitor
Published before and after this one in the same product
- ← EarlierCVE-2021-42361Nov 17, 2021 · Contact Form Email <= 1.3.24 Authenticated Stored Cross-Site Scripting19Monitor
- ← EarlierCVE-2023-2718Jun 12, 2023 · Contact Form Email < 1.3.38 - Unauthenticated Stored Cross-Site Scripting21Monitor
- Later →CVE-2024-31302Apr 10, 2024 · WordPress Contact Form Email plugin <= 1.3.44 - Sensitive Data Exposure vulnerability21Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Unknown Contact Form Email | 1.3.44 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- Mohamed Azarudheenfinder
- WPScancoordinator
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2023-2718182 days apartContact Form Email < 1.3.38 - Unauthenticated Stored Cross-Site Scripting21Monitor
- CVE-2025-24727410 days apartWordPress Contact Form to Email Plugin <= 1.3.52 - Cross Site Scripting (XSS) vulnerability19Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- Administrator privileges are required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
Impact can extend beyond the vulnerable component (scope changes).
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- Required
- Scope
- Changed
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
nvd-primary
Root cause
User content is inserted into the page as HTML. The browser interprets the content as code rather than data.
The bug in code
The whole CWE-79 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
commentEl.innerHTML = comment.body;Fixed
commentEl.textContent = comment.body;Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →