CVE-2023-5847: Under certain conditions, a low privileged attacker could load a specially crafted file during installation or upgrade to escalate privileg
Noroxi assessment
Priority: Monitor (action score 29/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.22% (FIRST EPSS).
- Someone with local access to the system can trigger it. A low-privileged account is enough. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: Tenable Nessus 10.6.2; Tenable Nessus Agent 10.4.3.
Low priority for now. Upgrade to Tenable Nessus 10.6.2; Tenable Nessus Agent 10.4.3 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Under certain conditions, a low privileged attacker could load a specially crafted file during installation or upgrade to escalate privileges on Windows and Linux hosts.
- Published
- Nov 1, 2023
- Updated
- Jun 17, 2026
- EPSS
- 0.2% · 12th percentile
- CWE
- CWE-269
Report tools
Action score
29
Monitor
Low priority for now.
- CVSS
- 29 / 40 · 7.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.2%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- total
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 7.3
- CNA · tenable
- 6.7
- 0.6 point gap
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| tenable | nessus | cpe:2.3:a:tenable:nessus |
| tenable | nessus agent | cpe:2.3:a:tenable:nessus_agent |
| linux | linux kernel | cpe:2.3:o:linux:linux_kernel |
| microsoft | windows | cpe:2.3:o:microsoft:windows |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- tenable nessusbefore 10.6.2
- tenable nessus agentbefore 10.4.3
Versions reported by the vendor
Affected version ranges reported by the assigning authority (tenable). Independent of NVD's CPE analysis and usually ahead of it.
Tenable Nessus
- before 10.6.2affected · 10.6.2
Tenable Nessus Agent
- before 10.4.3affected · 10.4.3
Same product
tenable: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-2005Tenable Plugin Feed ID #202306261202 Fixes Privilege Escalation Vulnerability35Monitor
- CVE-2022-4313A vulnerability was reported where through modifying the scan variables, an authenticated user in Tenable products, that has Scan Policy Con35Monitor
- CVE-2023-0524As part of our Security Development Lifecycle, a potential privilege escalation issue was identified internally.35Monitor
Published before and after this one in the same product
- ← EarlierCVE-2023-3252Aug 29, 2023 · Arbitrary File Write26Monitor
- ← EarlierCVE-2023-3253Aug 29, 2023 · Improper authorization in Nessus17Monitor
- Later →CVE-2023-6062Nov 20, 2023 · Arbitrary File Write26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| Tenable Nessus | 10.6.2 | Vendor (CNA) |
| Tenable Nessus Agent | 10.4.3 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2023-0524274 days apartAs part of our Security Development Lifecycle, a potential privilege escalation issue was identified internally.35Monitor
- CVE-2023-0101285 days apartA privilege escalation vulnerability was identified in Nessus versions 8.10.1 through 8.15.8 and 10.0.0 through 10.4.1.35Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- A low-privileged account is enough.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-269 · Improper Privilege ManagementCVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
nvd-primary
Root cause
To simplify setup, a service account is granted broad, cluster-wide permissions. The principle of least privilege is skipped during installation.
The bug in code
The whole CWE-269 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
kind: ClusterRole
rules:
- apiGroups: ["*"]
resources: ["*"]
verbs: ["*"]Fixed
kind: Role
metadata:
namespace: lodos-system
rules:
- apiGroups: ["apps"]
resources: ["deployments"]
verbs: ["get", "list", "update"]Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (1 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.