CVE-2022-47594: WordPress Essential Blocks for Gutenberg plugin <= 3.8.5 - Broken Access Control
Noroxi assessment
Priority: Monitor (action score 26/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.43% (FIRST EPSS).
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- According to CISA the attack is automatable: targets can be found by mass scanning.
- Fixed version: WPDeveloper Essential Blocks for Gutenberg 3.8.6.
Low priority for now. Upgrade to WPDeveloper Essential Blocks for Gutenberg 3.8.6 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Missing Authorization vulnerability in WPDeveloper Essential Blocks for Gutenberg allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Essential Blocks for Gutenberg: from n/a through 3.8.5.
- Published
- Dec 13, 2024
- Updated
- Jun 17, 2026
- EPSS
- 0.4% · 37th percentile
- CWE
- CWE-862
Report tools
Action score
26
Monitor
Low priority for now.
- CVSS
- 26 / 40 · 6.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.4%
CISA SSVC decision
- Exploitation
- none
- Automatable
- yes
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 6.5
- CNA · Patchstack
- 6.5
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Is Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| wpdeveloper | essential blocks | cpe:2.3:a:wpdeveloper:essential_blocks |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- wpdeveloper essential blocksbefore 3.8.6
Versions reported by the vendor
Affected version ranges reported by the assigning authority (Patchstack). Independent of NVD's CPE analysis and usually ahead of it.
WPDeveloper Essential Blocks for Gutenberg
- n/a and later · up to and including 3.8.5affectedfixed in 3.8.6
Same product
wpdeveloper: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-6623Essential Blocks < 4.4.3 - Unauthenticated Local File Inclusion54Plan
- CVE-2023-4402Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via products39Monitor
- CVE-2025-26871WordPress Essential Blocks plugin <= 4.8.3 - Broken Access Control vulnerability35Monitor
Published before and after this one in the same product
- ← EarlierCVE-2023-51359Dec 9, 2024 · WordPress Essential Blocks plugin <= 4.2.0 - Multiple Contributor+ Broken Access Control vulnerability35Monitor
- ← EarlierCVE-2023-51360Dec 9, 2024 · WordPress Essential Blocks plugin <= 4.2.0 - Multiple Subscriber+ Broken Access Control vulnerability35Monitor
- Later →CVE-2024-12045Jan 8, 2025 · Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates <= 5.0.9 - Authenticated (Admin+) Stored Cross-Site Scripting19Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| WPDeveloper Essential Blocks for Gutenberg | 3.8.6 | Vendor (CNA) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
- CVE-2023-477604 days apartWordPress Essential Blocks plugin <= 4.2.0 - Broken Access Control vulnerability35Monitor
- CVE-2023-513594 days apartWordPress Essential Blocks plugin <= 4.2.0 - Multiple Contributor+ Broken Access Control vulnerability35Monitor
- CVE-2023-513604 days apartWordPress Essential Blocks plugin <= 4.2.0 - Multiple Subscriber+ Broken Access Control vulnerability35Monitor
- CVE-2025-2687174 days apartWordPress Essential Blocks plugin <= 4.8.3 - Broken Access Control vulnerability35Monitor
- CVE-2024-30467187 days apartWordPress Essential Blocks plugin <= 4.4.9 - Broken Access Control vulnerability35Monitor
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-862 · Missing AuthorizationCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Vendor advisories and official records. Exploit/PoC links are deliberately left out.