CVE-2022-39269: Media transport downgrade from the secure version (SRTP) to non-secure (RTP) in pjsip
Noroxi assessment
Priority: Monitor (action score 36/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.73% (FIRST EPSS); higher than 54.5% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- According to CISA the attack is automatable: targets can be found by mass scanning.
- Fixed version: pjproject (Alpine:v3.18) 2.13-r0; asterisk (Debian:10) 1:16.28.0~dfsg-0+deb10u2; asterisk (Debian:11) 1:16.28.0~dfsg-0+deb11u2.
Low priority for now. Upgrade to pjproject (Alpine:v3.18) 2.13-r0; asterisk (Debian:10) 1:16.28.0~dfsg-0+deb10u2; asterisk (Debian:11) 1:16.28.0~dfsg-0+deb11u2 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
PJSIP is a free and open source multimedia communication library written in C. When processing certain packets, PJSIP may incorrectly switch from using SRTP media transport to using basic RTP upon SRTP restart, causing the media to be sent insecurely. The vulnerability impacts all PJSIP users that use SRTP. The patch is available as commit d2acb9a in the master branch of the project and will be included in version 2.13. Users are advised to manually patch or to upgrade. There are no known workarounds for this vulnerability.
- Published
- Oct 6, 2022
- Updated
- Jun 17, 2026
- EPSS
- 0.7% · 54th percentile
- CWE
- CWE-319
Report tools
Action score
36
Monitor
Low priority for now.
- CVSS
- 36 / 40 · 9.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.7%
CISA SSVC decision
- Exploitation
- none
- Automatable
- yes
- Technical impact
- total
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 9.1
- CNA · GitHub_M
- 9.1
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| teluu | pjsip | cpe:2.3:a:teluu:pjsip |
Check your site's encryption
This vulnerability is about certificate validation or weak cryptography. The free SSL checker tests your certificate, enabled TLS versions and weak ciphers.
Run the SSL checkAffected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- teluu pjsip2.11 and later · before 2.13
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
pjsip pjproject
- >= 2.11, < 2.13affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Alpine:v3.18 | pjproject | before 2.13-r0 | 2.13-r0 |
| Debian:10 | asterisk | before 1:16.28.0~dfsg-0+deb10u2 | 1:16.28.0~dfsg-0+deb10u2 |
| Debian:11 | asterisk | before 1:16.28.0~dfsg-0+deb11u2 | 1:16.28.0~dfsg-0+deb11u2 |
| Debian:12 | ring | before 20230206.0~ds1-1 | 20230206.0~ds1-1 |
| Debian:14 | asterisk | before 1:20.3.0~dfsg+~cs6.13.40431413-1 | 1:20.3.0~dfsg+~cs6.13.40431413-1 |
Same product
teluu: all recordsOther highest-scoring records for the same primary product.
- CVE-2022-31031Potential stack buffer overflow when parsing message as a STUN client40Plan
- CVE-2022-24754Buffer overflow in pjsip40Plan
- CVE-2022-23608Use after free in PJSIP40Plan
Published before and after this one in the same product
- ← EarlierCVE-2022-24763Mar 30, 2022 · Infinite Loop in PJSIP31Monitor
- ← EarlierCVE-2022-24792Apr 25, 2022 · Potential infinite loop when parsing WAV format file in PJSIP31Monitor
- Later →CVE-2022-23537Dec 20, 2022 · PJSIP vulnerable to heap buffer overflow when decoding STUN message39Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| alpine:pjproject | 2.13-r0 · Alpine:v3.18 | Package registry (OSV) |
| debian:asterisk | 1:20.3.0~dfsg+~cs6.13.40431413-1 · Debian:14 | Package registry (OSV) |
| debian:ring | 20230206.0~ds1-1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- None
Weakness class (CWE)
CWE-319 · Cleartext Transmission of Sensitive InformationCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (4 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.