CVE-2022-38170: Overly permissive umask for daemons
Noroxi assessment
Priority: Monitor (action score 18/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.61% (FIRST EPSS).
- Someone with local access to the system can trigger it. A low-privileged account is enough. No user action is required. Special conditions such as timing or configuration are required.
- Fixed version: apache-airflow (PyPI) 2.3.4.
Low priority for now. Upgrade to apache-airflow (PyPI) 2.3.4 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
In Apache Airflow prior to 2.3.4, an insecure umask was configured for numerous Airflow components when running with the `--daemon` flag which could result in a race condition giving world-writable files in the Airflow home directory and allowing local users to expose arbitrary file contents via the webserver.
- Published
- Sep 2, 2022
- Updated
- Jun 17, 2026
- EPSS
- 0.6% · 49th percentile
- CWE
- CWE-732
Report tools
Action score
18
Monitor
Low priority for now.
- CVSS
- 18 / 40 · 4.7 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.6%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| apache | airflow | cpe:2.3:a:apache:airflow |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- apache airflowbefore 2.3.4
Versions reported by the vendor
Affected version ranges reported by the assigning authority (apache). Independent of NVD's CPE analysis and usually ahead of it.
Apache Software Foundation Apache Airflow
- Apache Airflow and later · up to and including 2.3.3affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| PyPI | apache-airflow | before 2.3.4 | 2.3.4 |
Same product
apache: all recordsOther highest-scoring records for the same primary product.
- CVE-2020-13927The previous default setting for Airflow's Experimental API was to allow all API requests without authentication, but this poses security riKEV99Now
- CVE-2020-11978An issue was found in Apache Airflow versions 1.10.10 and below.KEV95Now
- CVE-2021-38540Apache Airflow: Variable Import endpoint missed authentication check63This week
Published before and after this one in the same product
- ← EarlierCVE-2022-24288Feb 25, 2022 · Apache Airflow: RCE in example DAGs58Plan
- ← EarlierCVE-2022-38054Sep 2, 2022 · In Apache Airflow versions 2.2.4 through 2.3.3, the `database` webserver session backend was susceptible to session fixation.40Plan
- Later →CVE-2022-40604Sep 21, 2022 · Format String Vulnerability31Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| PyPI:apache-airflow | 2.3.4 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- A low-privileged account is enough.
- No user action is required.
- Special conditions such as timing or configuration are required.
If successful
- Confidentiality
- high · data can be read
- Integrity
- none
- Availability
- none
- Attack vector
- Local
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- None
- Availability impact
- None
Weakness class (CWE)
CWE-732 · Incorrect Permission Assignment for Critical ResourceCVSS vector
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
- Accessing Functionality Not Properly Constrained by ACLsCAPEC-1likelihood: High · High
- Privilege AbuseCAPEC-122likelihood: High · Medium
- Directory IndexingCAPEC-127likelihood: High · Medium
- Using Malicious FilesCAPEC-17likelihood: High · Very High
- Exploiting Incorrectly Configured Access Control Security LevelsCAPEC-180likelihood: High · Medium
- Signing Malicious CodeCAPEC-206Very High
- Hijacking a privileged processCAPEC-234Medium
- Reusing Session IDs (aka Session Replay)CAPEC-60likelihood: High · High
ATT&CK techniques
- File and Directory DiscoveryT1083
- Access Token Manipulation:Token Impersonation/TheftT1134.001
- Server Software Component: Terminal Services DLLT1505.005
- Abuse Elevation Control MechanismT1548
- Use Alternate Authentication Material:Web Session CookieT1550.004
- Subvert Trust Controls:Code SigningT1553.002
- Compromise Client Software BinaryT1554
- Hijack Execution Flow:Executable Installer File Permissions WeaknessT1574.005
- Hijack Execution Flow: ServicesFile Permissions WeaknessT1574.010
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (3 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.