CVE-2022-34503: QPDF v8.4.2 was discovered to contain a heap buffer overflow via the function QPDF::processXRefStream.
Noroxi assessment
Priority: Monitor (action score 26/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.78% (FIRST EPSS); higher than 55.9% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: qpdf (Debian:12) 9.0.0-1; qpdf (openSUSE:Leap 15.3) 8.0.2-150000.3.5.1; qpdf (SUSE:Linux Enterprise High Performance Computing 15-ESPOS) 8.0.2-150000.3.5.1.
Low priority for now. Upgrade to qpdf (Debian:12) 9.0.0-1; qpdf (openSUSE:Leap 15.3) 8.0.2-150000.3.5.1; qpdf (SUSE:Linux Enterprise High Performance Computing 15-ESPOS) 8.0.2-150000.3.5.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
QPDF v8.4.2 was discovered to contain a heap buffer overflow via the function QPDF::processXRefStream. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted PDF file.
- Published
- Jul 22, 2022
- Updated
- Jun 17, 2026
- EPSS
- 0.7% · 55th percentile
- CWE
- CWE-787
Report tools
Action score
26
Monitor
Low priority for now.
- CVSS
- 26 / 40 · 6.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.7%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| qpdf project | qpdf | cpe:2.3:a:qpdf_project:qpdf |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- qpdf project qpdf8.4.2
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | qpdf | before 9.0.0-1 | 9.0.0-1 |
| openSUSE:Leap 15.3 | qpdf | before 8.0.2-150000.3.5.1 | 8.0.2-150000.3.5.1 |
| SUSE:Linux Enterprise High Performance Computing 15-ESPOS | qpdf | before 8.0.2-150000.3.5.1 | 8.0.2-150000.3.5.1 |
| SUSE:OpenStack Cloud 9 | qpdf | before 7.1.1-3.8.1 | 7.1.1-3.8.1 |
Same product
qpdf project: all recordsOther highest-scoring records for the same primary product.
- CVE-2018-9918libqpdf.a in QPDF through 8.0.2 mishandles certain "expected dictionary key but found non-name object" cases, allowing remote attackers to c32Monitor
- CVE-2017-12595The tokenizer in QPDF 6.0.0 and 7.0.b1 is recursive for arrays and dictionaries, which allows remote attackers to cause a denial of service 32Monitor
- CVE-2024-24246Heap Buffer Overflow vulnerability in qpdf 11.9.0 allows attackers to crash the application via the std::__shared_count() function at /bits/22Monitor
Published before and after this one in the same product
- ← EarlierCVE-2018-18020Oct 6, 2018 · In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which 13Monitor
- ← EarlierCVE-2021-36978Jul 20, 2021 · QPDF 9.x through 9.1.1 and 10.x through 10.0.4 has a heap-based buffer overflow in Pl_ASCII85Decoder::write (called from Pl_AES_PDF::flush a22Monitor
- Later →CVE-2021-25786Aug 11, 2023 · An issue was discovered in QPDF version 10.0.4, allows remote attackers to execute arbitrary code via crafted .pdf file to Pl_ASCII85Decoder21Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:qpdf | 9.0.0-1 · Debian:12 | Package registry (OSV) |
| opensuse:qpdf | 8.0.2-150000.3.5.1 · openSUSE:Leap 15.3 | Package registry (OSV) |
| suse:qpdf | 7.1.1-3.8.1 · SUSE:OpenStack Cloud 9 | Package registry (OSV) |
| suse:qpdf | 8.0.2-150000.3.5.1 · SUSE:Linux Enterprise High Performance Computing 15-ESPOS | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-787 · Out-of-bounds WriteCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →