CVE-2022-32293: In ConnMan through 1.41, a man-in-the-middle attack against a WISPR HTTP query could be used to trigger a use-after-free in WISPR handling,
Noroxi assessment
Priority: Monitor (action score 33/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 2% (FIRST EPSS); higher than 81% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. Special conditions such as timing or configuration are required.
- Fixed version: connman (Debian:10) 1.36-2.1~deb10u3, 1.36-2.1~deb10u4; connman (Debian:11) 1.36-2.2+deb11u1; connman (Debian:12) 1.41-2.
Low priority for now. Upgrade to connman (Debian:10) 1.36-2.1~deb10u3, 1.36-2.1~deb10u4; connman (Debian:11) 1.36-2.2+deb11u1; connman (Debian:12) 1.41-2 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
In ConnMan through 1.41, a man-in-the-middle attack against a WISPR HTTP query could be used to trigger a use-after-free in WISPR handling, leading to crashes or code execution.
- Published
- Aug 3, 2022
- Updated
- Jun 17, 2026
- EPSS
- 2.0% · 81th percentile
- CWE
- CWE-416
Report tools
Action score
33
Monitor
Low priority for now.
- CVSS
- 32 / 40 · 8.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 2.0%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- debian debian linux11.0
- intel connmanup to 1.41 inclusive
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:10 | connman | before 1.36-2.1~deb10u3 | 1.36-2.1~deb10u3 |
| Debian:10 | connman | before 1.36-2.1~deb10u4 | 1.36-2.1~deb10u4 |
| Debian:11 | connman | before 1.36-2.2+deb11u1 | 1.36-2.2+deb11u1 |
| Debian:12 | connman | before 1.41-2 | 1.41-2 |
| openSUSE:Leap 15.3 | connman | before 1.41-bp153.2.6.1 | 1.41-bp153.2.6.1 |
| openSUSE:Leap 15.4 | connman | before 1.41-bp154.2.3.1 | 1.41-bp154.2.3.1 |
| openSUSE:Tumbleweed | connman | before 1.41-4.1 | 1.41-4.1 |
| SUSE:Package Hub 15 SP3 | connman | before 1.41-bp153.2.6.1 | 1.41-bp153.2.6.1 |
| SUSE:Package Hub 15 SP4 | connman | before 1.41-bp154.2.3.1 | 1.41-bp154.2.3.1 |
Same product
intel: all recordsOther highest-scoring records for the same primary product.
- CVE-2017-12865Stack-based buffer overflow in "dnsproxy.c" in connman 1.34 and earlier allows remote attackers to cause a denial of service (crash) or exec41Plan
- CVE-2022-32292In ConnMan through 1.41, remote attackers able to send HTTP requests to the gweb component are able to exploit a heap-based buffer overflow 40Plan
- CVE-2022-23097An issue was discovered in the DNS proxy in Connman through 1.40.37Monitor
Published before and after this one in the same product
- ← EarlierCVE-2022-23096Jan 28, 2022 · An issue was discovered in the DNS proxy in Connman through 1.40.37Monitor
- ← EarlierCVE-2022-23098Jan 28, 2022 · An issue was discovered in the DNS proxy in Connman through 1.40.31Monitor
- Later →CVE-2023-28488Apr 12, 2023 · client.c in gdhcp in ConnMan through 1.41 could be used by network-adjacent attackers (operating a crafted DHCP server) to cause a stack-bas26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:connman | 1.41-2 · Debian:12 | Package registry (OSV) |
| opensuse:connman | 1.41-bp154.2.3.1 · openSUSE:Leap 15.4 | Package registry (OSV) |
| suse:connman | 1.41-bp154.2.3.1 · SUSE:Package Hub 15 SP4 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- Special conditions such as timing or configuration are required.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-416 · Use After FreeCVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
nvd-primary
Root cause
After a memory region is freed, another reference pointing to it is still used. By then, the same region may have been allocated for different data.
The bug in code
The whole CWE-416 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
free(dev->buf);
/* ... another thread is still running ... */
process(dev->buf);Fixed
lock(&dev->lock);
free(dev->buf);
dev->buf = NULL;
unlock(&dev->lock);Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (4 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.