CVE-2022-1475: An integer overflow vulnerability was found in FFmpeg versions before 4.4.2 and before 5.0.1 in g729_parse() in llibavcodec/g729_parser.c wh
Noroxi assessment
Priority: Monitor (action score 22/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.93% (FIRST EPSS); higher than 60.3% of all records.
- Someone with local access to the system can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: ffmpeg (Debian:11) 7:4.3.4-0+deb11u1; ffmpeg (Debian:12) 7:4.4.2-1; ffmpeg (openSUSE:Leap 15.6) 3.4.2-150200.11.64.1.
Low priority for now. Upgrade to ffmpeg (Debian:11) 7:4.3.4-0+deb11u1; ffmpeg (Debian:12) 7:4.4.2-1; ffmpeg (openSUSE:Leap 15.6) 3.4.2-150200.11.64.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
An integer overflow vulnerability was found in FFmpeg versions before 4.4.2 and before 5.0.1 in g729_parse() in llibavcodec/g729_parser.c when processing a specially crafted file.
- Published
- May 2, 2022
- Updated
- Jun 17, 2026
- EPSS
- 0.9% · 60th percentile
- CWE
- CWE-190
Report tools
Action score
22
Monitor
Low priority for now.
- CVSS
- 22 / 40 · 5.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.9%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| ffmpeg | ffmpeg | cpe:2.3:a:ffmpeg:ffmpeg |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- ffmpeg ffmpeg4.2 and later · before 4.4.2
- ffmpeg ffmpeg5.0
Versions reported by the vendor
Affected version ranges reported by the assigning authority (fedora). Independent of NVD's CPE analysis and usually ahead of it.
n/a FFmpeg
- before 4.4.2, before 5.0.1affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:11 | ffmpeg | before 7:4.3.4-0+deb11u1 | 7:4.3.4-0+deb11u1 |
| Debian:12 | ffmpeg | before 7:4.4.2-1 | 7:4.4.2-1 |
| openSUSE:Leap 15.6 | ffmpeg | before 3.4.2-150200.11.64.1 | 3.4.2-150200.11.64.1 |
| openSUSE:Tumbleweed | ffmpeg-4 | before 4.4.6-4.1 | 4.4.6-4.1 |
| SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | ffmpeg | before 3.4.2-150200.11.64.1 | 3.4.2-150200.11.64.1 |
Same product
ffmpeg: all recordsOther highest-scoring records for the same primary product.
- CVE-2009-4637FFmpeg 0.5 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger45Plan
- CVE-2016-10190Heap-based buffer overflow in libavformat/http.c in FFmpeg before 2.8.10, 3.0.x before 3.0.5, 3.1.x before 3.1.6, and 3.2.x before 3.2.2 all42Plan
- CVE-2009-4634Multiple integer underflows in FFmpeg 0.5 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a craf42Plan
Published before and after this one in the same product
- ← EarlierCVE-2021-38094Sep 20, 2021 · Integer Overflow vulnerability in function filter_sobel in libavfilter/vf_convolution.c in Ffmpeg 4.2.1, allows attackers to cause a Denial 35Monitor
- ← EarlierCVE-2020-23906Nov 10, 2021 · FFmpeg N-98388-g76a3ee996b allows attackers to cause a denial of service (DoS) via a crafted audio file due to insufficient verification of 22Monitor
- Later →CVE-2014-125002Jun 18, 2022 · FFmpeg dnxhdenc.c dnxhd_init_rc memory corruption22Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:ffmpeg | 7:4.4.2-1 · Debian:12 | Package registry (OSV) |
| opensuse:ffmpeg | 3.4.2-150200.11.64.1 · openSUSE:Leap 15.6 | Package registry (OSV) |
| opensuse:ffmpeg-4 | 4.4.6-4.1 · openSUSE:Tumbleweed | Package registry (OSV) |
| suse:ffmpeg | 3.4.2-150200.11.64.1 · SUSE:Linux Enterprise Module for Desktop Applications 15 SP6 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-190 · Integer Overflow or WraparoundCVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (1 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.