CVE-2021-41241: Advanced permissions is not respected for subfolders in Nextcloud server
Noroxi assessment
Priority: Monitor (action score 17/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.85% (FIRST EPSS); higher than 57.8% of all records.
- Anyone who can reach it over the internet can trigger it. A low-privileged account is enough. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: nextcloud (openSUSE:Leap 15.3) 21.0.9-bp153.2.12.1; nextcloud (SUSE:Package Hub 12) 21.0.9-37.1; nextcloud (SUSE:Package Hub 15 SP3) 21.0.9-bp153.2.12.1.
Low priority for now. Upgrade to nextcloud (openSUSE:Leap 15.3) 21.0.9-bp153.2.12.1; nextcloud (SUSE:Package Hub 12) 21.0.9-37.1; nextcloud (SUSE:Package Hub 15 SP3) 21.0.9-bp153.2.12.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Nextcloud server is a self hosted system designed to provide cloud style services. The groupfolders application for Nextcloud allows sharing a folder with a group of people. In addition, it allows setting "advanced permissions" on subfolders, for example, a user could be granted access to the groupfolder but not specific subfolders. Due to a lacking permission check in affected versions, a user could still access these subfolders by copying the groupfolder to another location. It is recommended that the Nextcloud Server is upgraded to 20.0.14, 21.0.6 or 22.2.1. Users unable to upgrade should disable the "groupfolders" application in the admin settings.
- Published
- Mar 8, 2022
- Updated
- Jun 17, 2026
- EPSS
- 0.8% · 57th percentile
- CWE
- CWE-863
Report tools
Action score
17
Monitor
Low priority for now.
- CVSS
- 17 / 40 · 4.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.8%
CISA SSVC decision
- Exploitation
- none
- Automatable
- no
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 4.3
- CNA · GitHub_M
- 4.3
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| nextcloud | nextcloud server | cpe:2.3:a:nextcloud:nextcloud_server |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- nextcloud nextcloud serverbefore 20.0.14
- nextcloud nextcloud server21.0.0 and later · before 21.0.6
- nextcloud nextcloud server22.2.0
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
nextcloud security-advisories
- < 20.0.14, >= 21.0.0, < 21.0.6, >= 22.2.0, < 22.2.1affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| openSUSE:Leap 15.3 | nextcloud | before 21.0.9-bp153.2.12.1 | 21.0.9-bp153.2.12.1 |
| SUSE:Package Hub 12 | nextcloud | before 21.0.9-37.1 | 21.0.9-37.1 |
| SUSE:Package Hub 15 SP3 | nextcloud | before 21.0.9-bp153.2.12.1 | 21.0.9-bp153.2.12.1 |
Same product
nextcloud: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-26482Scope of workflow operations is not validated in nextcloud server40Plan
- CVE-2021-32802Preview generation used third-party library not suited for user-generated content in Nextcloud server40Plan
- CVE-2021-32726Webauthn tokens not removed after user has been deleted40Plan
Published before and after this one in the same product
- ← EarlierCVE-2021-41177Oct 25, 2021 · Rate-limits not working on instances without configured memory cache backend32Monitor
- ← EarlierCVE-2021-41239Mar 8, 2022 · User enumeration setting not respected in Nextcloud server21Monitor
- Later →CVE-2022-24741Mar 9, 2022 · High memory usage in Nextcloud server26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| opensuse:nextcloud | 21.0.9-bp153.2.12.1 · openSUSE:Leap 15.3 | Package registry (OSV) |
| suse:nextcloud | 21.0.9-37.1 · SUSE:Package Hub 12 | Package registry (OSV) |
| suse:nextcloud | 21.0.9-bp153.2.12.1 · SUSE:Package Hub 15 SP3 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- A low-privileged account is enough.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- none
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- Low
- Integrity impact
- None
- Availability impact
- None
Weakness class (CWE)
CWE-863 · Incorrect AuthorizationCVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (3 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.