CVE-2021-32055: Mutt 1.11.0 through 2.0.x before 2.0.7 (and NeoMutt 2019-10-25 through 2021-05-04) has a $imap_qresync issue in which imap/util.c has an out
Noroxi assessment
Priority: Monitor (action score 37/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 2.5% (FIRST EPSS); higher than 85% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: mutt (Debian:12) 2.0.5-4.1; neomutt (Debian:12) 20201127+dfsg.1-1.2; neomutt (openSUSE:Leap 15.4) 20220429-bp154.2.3.1.
Low priority for now. Upgrade to mutt (Debian:12) 2.0.5-4.1; neomutt (Debian:12) 20201127+dfsg.1-1.2; neomutt (openSUSE:Leap 15.4) 20220429-bp154.2.3.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Mutt 1.11.0 through 2.0.x before 2.0.7 (and NeoMutt 2019-10-25 through 2021-05-04) has a $imap_qresync issue in which imap/util.c has an out-of-bounds read in situations where an IMAP sequence set ends with a comma. NOTE: the $imap_qresync setting for QRESYNC is not enabled by default.
- Published
- May 5, 2021
- Updated
- Jun 16, 2026
- EPSS
- 2.5% · 85th percentile
- CWE
- CWE-125
Report tools
Action score
37
Monitor
Low priority for now.
- CVSS
- 36 / 40 · 9.1 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 2.5%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- mutt mutt1.11.0 and later · before 2.0.7
- neomutt neomutt20191025 and later · up to 20210504 inclusive
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | mutt | before 2.0.5-4.1 | 2.0.5-4.1 |
| Debian:12 | neomutt | before 20201127+dfsg.1-1.2 | 20201127+dfsg.1-1.2 |
| openSUSE:Leap 15.4 | neomutt | before 20220429-bp154.2.3.1 | 20220429-bp154.2.3.1 |
| openSUSE:Tumbleweed | neomutt | before 20211029-1.1 | 20211029-1.1 |
| SUSE:Package Hub 15 SP4 | neomutt | before 20220429-bp154.2.3.1 | 20220429-bp154.2.3.1 |
Same product
mutt: all recordsOther highest-scoring records for the same primary product.
- CVE-2018-14354An issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16.41Plan
- CVE-2018-14362An issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16.40Plan
- CVE-2018-14359An issue was discovered in Mutt before 1.10.1 and NeoMutt before 2018-07-16.40Plan
Published before and after this one in the same product
- ← EarlierCVE-2020-28896Nov 23, 2020 · Mutt before 2.0.2 and NeoMutt before 2020-11-20 did not ensure that $ssl_force_tls was processed if an IMAP server's initial server response22Monitor
- ← EarlierCVE-2021-3181Jan 19, 2021 · rfc822.c in Mutt through 2.0.4 allows remote attackers to cause a denial of service (mailbox unavailability) by sending email messages with 27Monitor
- Later →CVE-2022-1328Apr 14, 2022 · Buffer Overflow in uudecoder in Mutt affecting all versions starting from 0.94.13 before 2.2.3 allows read past end of input line22Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:mutt | 2.0.5-4.1 · Debian:12 | Package registry (OSV) |
| debian:neomutt | 20201127+dfsg.1-1.2 · Debian:12 | Package registry (OSV) |
| opensuse:neomutt | 20220429-bp154.2.3.1 · openSUSE:Leap 15.4 | Package registry (OSV) |
| suse:neomutt | 20220429-bp154.2.3.1 · SUSE:Package Hub 15 SP4 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-125 · Out-of-bounds ReadCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (3 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.