CVE-2021-29449: Multiple Privilege Escalation Vulnerabilities Pihole
Noroxi assessment
Priority: Plan (action score 40/100)
- A ready-made attack module is public (Metasploit); exploiting it takes no special expertise.
- Because a ready-made attack tool exists, priority is at least “Plan”.
- Probability of exploitation in the next 30 days: 1.8% (FIRST EPSS); higher than 79% of all records.
- Someone with local access to the system can trigger it. A low-privileged account is enough. No user action is required. No special conditions are required; it is repeatable.
- According to the record, no fixed version is available yet.
Add it to your regular patch cycle. Update when a fix is released; follow the vendor's advisory.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
Pi-hole is a Linux network-level advertisement and Internet tracker blocking application. Multiple privilege escalation vulnerabilities were discovered in version 5.2.4 of Pi-hole core. See the referenced GitHub security advisory for details.
- Published
- Apr 14, 2021
- Updated
- Jun 16, 2026
- EPSS
- 1.8% · 79th percentile
- CWE
- CWE-269
Report tools
Action score
40
Plan
Add it to your regular patch cycle.
- CVSS
- 31 / 40 · 7.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 1.8%
- Ready-made attack tool
- 8 / 40 · floor: at least 40
CNA vs NVD score
- NVD
- 7.8
- CNA · GitHub_M
- 6.3
- 1.5 point gap
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- Weaponized exploit exists
- No fixed version yet
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| pi-hole | pi-hole | cpe:2.3:a:pi-hole:pi-hole |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- pi-hole pi-holeup to 5.2.4 inclusive
Versions reported by the vendor
Affected version ranges reported by the assigning authority (GitHub_M). Independent of NVD's CPE analysis and usually ahead of it.
pi-hole pi-hole
- <= 5.2.4affected
Same product
pi-hole: all recordsOther highest-scoring records for the same primary product.
- CVE-2020-8816Pi-hole Web v4.3.2 (aka AdminLTE) allows Remote Code Execution by privileged dashboard users via a crafted DHCP static lease.KEV82Now
- CVE-2020-11108The Gravity updater in Pi-hole through 4.4 allows an authenticated adversary to upload arbitrary files.58Plan
- CVE-2021-32706(Authenticated) Remote Code Execution Possible in Web Interface 5.553Plan
Published before and after this one in the same product
- ← EarlierCVE-2020-35591Feb 18, 2021 · Pi-hole 5.0, 5.1, and 5.1.1 allows Session Fixation.21Monitor
- ← EarlierCVE-2020-35592Feb 18, 2021 · Pi-hole 5.0, 5.1, and 5.1.1 allows XSS via the Options header to the admin/ URI.21Monitor
- Later →CVE-2021-32793Aug 4, 2021 · Stored XSS Vulnerability in the Pi-hole Webinterface19Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
No fix version is recorded for this entry. Check the references for vendor advisories.
Exploit status
Weaponized
A ready exploit tool or active in-the-wild use is known for this vulnerability. This should be your top priority.
Evidence
- Metasploit module ×1
Noroxi does not host or link to exploit code. Metasploit module names and Nuclei template ids are shown (names, not code); Exploit-DB entries and PoC repositories are given as counts only.
| Source | Kind | Date |
|---|---|---|
| Metasploit module | exploit/linux/local/pihole_remove_commands_lpePi-Hole Remove Commands Linux Priv Escexploit | 2021-04-20 |
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
- Published
- Metasploit+5 d
- TodayNov 3, 2026+2028 d
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- A low-privileged account is enough.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-269 · Improper Privilege ManagementCVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
nvd-primary
Root cause
To simplify setup, a service account is granted broad, cluster-wide permissions. The principle of least privilege is skipped during installation.
The bug in code
The whole CWE-269 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
kind: ClusterRole
rules:
- apiGroups: ["*"]
resources: ["*"]
verbs: ["*"]Fixed
kind: Role
metadata:
namespace: lodos-system
rules:
- apiGroups: ["apps"]
resources: ["deployments"]
verbs: ["get", "list", "update"]Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
No changes recorded on tracked fields yet. Score, KEV, exploit maturity and fix status changes appear here.