CVE-2021-25973: Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
Noroxi assessment
Priority: Monitor (action score 26/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 0.82% (FIRST EPSS); higher than 57.3% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- According to CISA the attack is automatable: targets can be found by mass scanning.
- Fixed version: publify_core (RubyGems) 9.2.5.
Low priority for now. Upgrade to publify_core (RubyGems) 9.2.5 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
In Publify, 9.0.0.pre1 to 9.2.4 are vulnerable to Improper Access Control. “guest” role users can self-register even when the admin does not allow. This happens due to front-end restriction only.
- Published
- Nov 2, 2021
- Updated
- Jun 16, 2026
- EPSS
- 0.8% · 57th percentile
- CWE
- CWE-285
Report tools
Action score
26
Monitor
Low priority for now.
- CVSS
- 26 / 40 · 6.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 0.8%
CISA SSVC decision
- Exploitation
- proof of concept
- Automatable
- yes
- Technical impact
- partial
Vulnrichment: CISA's decision-tree inputs.
CNA vs NVD score
- NVD
- 6.5
- CNA · Mend
- 6.5
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| publify project | publify | cpe:2.3:a:publify_project:publify |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- publify project publify9.0.0 and later · up to 9.2.4 inclusive
Versions reported by the vendor
Affected version ranges reported by the assigning authority (Mend). Independent of NVD's CPE analysis and usually ahead of it.
publify_core publify_core
- 9.0.0.pre1 and later · before unspecifiedaffected
- unspecified and later · up to and including 9.2.4affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| RubyGems | publify_core | from 9.0.0.pre1 · before 9.2.5 | 9.2.5 |
Same product
publify project: all recordsOther highest-scoring records for the same primary product.
- CVE-2022-1812Integer Overflow or Wraparound in publify/publify48Plan
- CVE-2023-0299Improper Input Validation in publify/publify39Monitor
- CVE-2022-0524Business Logic Errors in publify/publify30Monitor
Published before and after this one in the same product
- Later →CVE-2021-25974Nov 10, 2021 · Publify - Stored Cross-Site Scripting (XSS) in Editor21Monitor
- Later →CVE-2021-25975Nov 10, 2021 · Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload21Monitor
- Later →CVE-2022-0574May 16, 2022 · Improper Access Control in publify/publify26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| RubyGems:publify_core | 9.2.5 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- low · data can be read
- Integrity
- low · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- Low
- Integrity impact
- Low
- Availability impact
- None
Weakness class (CWE)
CWE-285 · Improper AuthorizationCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
- Accessing Functionality Not Properly Constrained by ACLsCAPEC-1likelihood: High · High
- Cross Zone ScriptingCAPEC-104likelihood: Medium · High
- Directory IndexingCAPEC-127likelihood: High · Medium
- Subverting Environment Variable ValuesCAPEC-13likelihood: High · Very High
- Using Malicious FilesCAPEC-17likelihood: High · Very High
- Manipulating Opaque Client-based Data TokensCAPEC-39likelihood: High · Medium
- Bypassing ATA Password SecurityCAPEC-402
- Buffer Overflow via Symbolic LinksCAPEC-45likelihood: High · High
ATT&CK techniques
- Data from Local SystemT1005
- Query RegistryT1012
- File and Directory DiscoveryT1083
- Access Token Manipulation:Token Impersonation/TheftT1134.001
- Use Alternate Authentication Material:Web Session CookieT1550.004
- Unsecured Credentials: Credentials in RegistryT1552.002
- Impair Defenses:Impair Command History LoggingT1562.003
- Data Manipulation: Transmitted Data ManipulationT1565.002
- Hijack Execution Flow: Executable Installer File Permissions WeaknessT1574.005
- Hijack Execution Flow:Dynamic Linker HijackingT1574.006
- Hijack Execution Flow:Path Interception by PATH Environment VariableT1574.007
- Hijack Execution Flow: ServicesFile Permissions WeaknessT1574.010
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (1 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.