CVE-2020-7067: OOB Read in urldecode()
Noroxi assessment
Priority: Monitor (action score 31/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 4.3% (FIRST EPSS); higher than 91.1% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: php7.3 (Debian:10) 7.3.19-1~deb10u1; php7.4 (Debian:11) 7.4.5-1; php5 (Debian:8) 5.6.40+dfsg-0+deb8u11.
- Mentioned 1 time in Turkish national cyber security advisories (siberguvenlik.gov.tr).
Low priority for now. Upgrade to php7.3 (Debian:10) 7.3.19-1~deb10u1; php7.4 (Debian:11) 7.4.5-1; php5 (Debian:8) 5.6.40+dfsg-0+deb8u11 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
In PHP versions 7.2.x below 7.2.30, 7.3.x below 7.3.17 and 7.4.x below 7.4.5, if PHP is compiled with EBCDIC support (uncommon), urldecode() function can be made to access locations past the allocated memory, due to erroneously using signed numbers as array indexes.
- Published
- Apr 27, 2020
- Updated
- Jun 16, 2026
- EPSS
- 4.3% · 91th percentile
- CWE
- CWE-125
Report tools
Action score
31
Monitor
Low priority for now.
- CVSS
- 30 / 40 · 7.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 4.3%
CNA vs NVD score
- NVD
- 7.5
- CNA · php
- 7.5
- agree
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| php | php | cpe:2.3:a:php:php |
| tenable | tenable.sc | cpe:2.3:a:tenable:tenable.sc |
| oracle | communications diameter signaling router | cpe:2.3:a:oracle:communications_diameter_signaling_router |
| debian | debian linux | cpe:2.3:o:debian:debian_linux |
Using php? Add it to your stack and be the first to know about CVEs like this one. (PHP)
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- php php7.2.0 and later · before 7.2.30
- php php7.3.0 and later · before 7.3.17
- php php7.4.0 and later · before 7.4.5
Versions reported by the vendor
Affected version ranges reported by the assigning authority (php). Independent of NVD's CPE analysis and usually ahead of it.
PHP Group PHP
- 7.2.x below 7.2.30, 7.3.x below 7.3.17 and 7.4.x below 7.4.5affected
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:10 | php7.3 | before 7.3.19-1~deb10u1 | 7.3.19-1~deb10u1 |
| Debian:11 | php7.4 | before 7.4.5-1 | 7.4.5-1 |
| Debian:8 | php5 | before 5.6.40+dfsg-0+deb8u11 | 5.6.40+dfsg-0+deb8u11 |
| Debian:9 | php7.0 | before 7.0.33-0+deb9u8 | 7.0.33-0+deb9u8 |
Same product
php: all recordsOther highest-scoring records for the same primary product.
- CVE-2024-4577Argument Injection in PHP-CGIKEV99Now
- CVE-2019-11043Underflow in PHP-FPM can lead to RCEKEV99Now
- CVE-2012-1823sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI script (aka php-cgi), does not properly handle queKEV99Now
Published before and after this one in the same product
- ← EarlierCVE-2020-7065Apr 1, 2020 · mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full36Monitor
- ← EarlierCVE-2020-7066Apr 1, 2020 · get_headers() silently truncates after a null byte18Monitor
- Later →CVE-2019-11048May 20, 2020 · Temporary files are not cleaned after OOM when parsing HTTP request data23Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:php5 | 5.6.40+dfsg-0+deb8u11 · Debian:8 | Package registry (OSV) |
| debian:php7.0 | 7.0.33-0+deb9u8 · Debian:9 | Package registry (OSV) |
| debian:php7.3 | 7.3.19-1~deb10u1 · Debian:10 | Package registry (OSV) |
| debian:php7.4 | 7.4.5-1 · Debian:11 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
- bigshaqwearehackerone dot com
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
National notice (Türkiye Cybersecurity Directorate / USOM)
Official security notices citing this record; remediation advice is on the agency's page.
- TR-20-271 · Apr 27, 2020(PHP için Güvenlik Güncellemeleri Yayınladı)
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- none
- Availability
- none
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- None
- Availability impact
- None
Weakness class (CWE)
CWE-125 · Out-of-bounds ReadCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (5 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.