CVE-2020-24972: The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr:
Noroxi assessment
Priority: Monitor (action score 36/100)
- Public proof-of-concept code exists (GitHub); there is no record of exploitation in the wild.
- Probability of exploitation in the next 30 days: 4.8% (FIRST EPSS); higher than 91.9% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: kleopatra (Debian:12) 4:20.08.2-2; kleopatra (openSUSE:Leap 15.1) 18.12.3-lp151.2.4.1; kleopatra (SUSE:Package Hub 15 SP1) 18.12.3-bp151.3.3.1.
Low priority for now. Upgrade to kleopatra (Debian:12) 4:20.08.2-2; kleopatra (openSUSE:Leap 15.1) 18.12.3-lp151.2.4.1; kleopatra (SUSE:Package Hub 15 SP1) 18.12.3-bp151.3.3.1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.
- Published
- Aug 29, 2020
- Updated
- Jun 16, 2026
- EPSS
- 4.8% · 91th percentile
- CWE
- CWE-116
Report tools
Action score
36
Monitor
Low priority for now.
- CVSS
- 35 / 40 · 8.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 4.8%
CNA vs NVD score
- NVD
- 8.8
- CNA · mitre
- 8.8
- agree
CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:R
The score given by the assigning authority versus NVD’s independent score. A gap means the severity is contested.
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- Proof of concept exists, no weaponized module
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| kleopatra project | kleopatra | cpe:2.3:a:kleopatra_project:kleopatra |
| fedoraproject | fedora | cpe:2.3:o:fedoraproject:fedora |
| opensuse | backports sle | cpe:2.3:a:opensuse:backports_sle |
| opensuse | leap | cpe:2.3:o:opensuse:leap |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- fedoraproject fedora32
- kleopatra project kleopatrabefore 20.07.80
- opensuse backports sle15.0
- opensuse leap15.1
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | kleopatra | before 4:20.08.2-2 | 4:20.08.2-2 |
| openSUSE:Leap 15.1 | kleopatra | before 18.12.3-lp151.2.4.1 | 18.12.3-lp151.2.4.1 |
| SUSE:Package Hub 15 SP1 | kleopatra | before 18.12.3-bp151.3.3.1 | 18.12.3-bp151.3.3.1 |
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:kleopatra | 4:20.08.2-2 · Debian:12 | Package registry (OSV) |
| opensuse:kleopatra | 18.12.3-lp151.2.4.1 · openSUSE:Leap 15.1 | Package registry (OSV) |
| suse:kleopatra | 18.12.3-bp151.3.3.1 · SUSE:Package Hub 15 SP1 | Package registry (OSV) |
Exploit status
Proof of concept available
A public proof of concept or detection signature exists. Exploit knowledge is out there; don't delay patching.
Evidence
- Proof-of-concept repository on GitHub ×1
Noroxi does not host or link to exploit code. Metasploit module names and Nuclei template ids are shown (names, not code); Exploit-DB entries and PoC repositories are given as counts only.
| Source | Kind | Date |
|---|---|---|
| Proof-of-concept repository on GitHub | stars:1 | 2024-09-01 |
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
- Published
- First PoC+1463 d
- TodayOct 27, 2026+2250 d
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-116 · Improper Encoding or Escaping of OutputCVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (4 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.