CVE-2019-18849: In tnef before 1.4.18, an attacker may be able to write to the victim's .ssh/authorized_keys file via an e-mail message with a crafted winma
Noroxi assessment
Priority: Monitor (action score 22/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 1.2% (FIRST EPSS); higher than 68% of all records.
- Someone with local access to the system can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: tnef (Debian:12) 1.4.18-1; tnef (Debian:8) 1.4.9-1+deb8u4; tnef (Debian:9) 1.4.12-1.2+deb9u1.
Low priority for now. Upgrade to tnef (Debian:12) 1.4.18-1; tnef (Debian:8) 1.4.9-1+deb8u4; tnef (Debian:9) 1.4.12-1.2+deb9u1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
In tnef before 1.4.18, an attacker may be able to write to the victim's .ssh/authorized_keys file via an e-mail message with a crafted winmail.dat application/ms-tnef attachment, because of a heap-based buffer over-read involving strdup.
- Published
- Nov 11, 2019
- Updated
- Jun 16, 2026
- EPSS
- 1.2% · 68th percentile
- CWE
- CWE-125
Report tools
Action score
22
Monitor
Low priority for now.
- CVSS
- 22 / 40 · 5.5 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 1.2%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| tnef project | tnef | cpe:2.3:a:tnef_project:tnef |
| fedoraproject | fedora | cpe:2.3:o:fedoraproject:fedora |
| canonical | ubuntu linux | cpe:2.3:o:canonical:ubuntu_linux |
| debian | debian linux | cpe:2.3:o:debian:debian_linux |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- canonical ubuntu linux16.04
- debian debian linux8.0
- fedoraproject fedora30
- fedoraproject fedora31
- tnef project tnefbefore 1.4.18
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | tnef | before 1.4.18-1 | 1.4.18-1 |
| Debian:8 | tnef | before 1.4.9-1+deb8u4 | 1.4.9-1+deb8u4 |
| Debian:9 | tnef | before 1.4.12-1.2+deb9u1 | 1.4.12-1.2+deb9u1 |
Same product
tnef project: all recordsOther highest-scoring records for the same primary product.
- CVE-2017-8911An integer underflow has been identified in the unicode_to_utf8() function in tnef 1.4.14.40Plan
- CVE-2026-103678Tnef: heap out-of-bounds read in get_rtf_data_from_buf() via uncompressed rtf mapi value32Monitor
- CVE-2017-6310An issue was discovered in tnef before 1.4.13.31Monitor
Published before and after this one in the same product
- ← EarlierCVE-2017-6308Feb 24, 2017 · An issue was discovered in tnef before 1.4.13.31Monitor
- ← EarlierCVE-2017-6309Feb 24, 2017 · An issue was discovered in tnef before 1.4.13.31Monitor
- Later →CVE-2026-103679Oct 1, 2026 · Tnef: use-after-free and double-free in get_body_files() via multi-value body extraction26Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:tnef | 1.4.18-1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Someone with local access to the system can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- none
- Integrity
- none
- Availability
- high · the service can be disrupted
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- None
- Availability impact
- High
Weakness class (CWE)
CWE-125 · Out-of-bounds ReadCVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (5 more)Show less
- lists.debian.org/debian-lts-announce/2019/11/msg00035.html
- lists.debian.org/debian-lts-announce/2021/08/msg00025.html
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RMKFSHPMOZL7MDWU5RYOTIBTRWSZ4Z6X/
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W7CPKBW4QZ4VIY4UXIUVUSHRJ4R2FROE/
- usn.ubuntu.com/4524-1/
Vendor advisories and official records. Exploit/PoC links are deliberately left out.