CVE-2019-17669: WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of
Noroxi assessment
Priority: Plan (action score 41/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 5.2% (FIRST EPSS); higher than 92.5% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. No user action is required. No special conditions are required; it is repeatable.
- Fixed version: wordpress (Debian:10) 5.0.4+dfsg1-1+deb10u1; wordpress (Debian:12) 5.2.4+dfsg1-1; wordpress (Debian:8) 4.1.28+dfsg-0+deb8u1.
Add it to your regular patch cycle. Upgrade to wordpress (Debian:10) 5.0.4+dfsg1-1+deb10u1; wordpress (Debian:12) 5.2.4+dfsg1-1; wordpress (Debian:8) 4.1.28+dfsg-0+deb8u1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of a name as a series of hex characters.
- Published
- Oct 17, 2019
- Updated
- Jun 16, 2026
- EPSS
- 5.2% · 92th percentile
- CWE
- CWE-918
Report tools
Action score
41
Plan
Add it to your regular patch cycle.
- CVSS
- 39 / 40 · 9.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 2 / 30 · 5.2%
Is WordPress on your site?
WP Lens reads your site's plugin, theme and WordPress versions from the outside and matches them to known vulnerabilities. Works without an account.
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| wordpress | wordpress | cpe:2.3:a:wordpress:wordpress |
| debian | debian linux | cpe:2.3:o:debian:debian_linux |
Using wordpress? Add it to your stack and be the first to know about CVEs like this one. (WordPress)
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- wordpress wordpressbefore 5.2.4
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:10 | wordpress | before 5.0.4+dfsg1-1+deb10u1 | 5.0.4+dfsg1-1+deb10u1 |
| Debian:12 | wordpress | before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
| Debian:8 | wordpress | before 4.1.28+dfsg-0+deb8u1 | 4.1.28+dfsg-0+deb8u1 |
Same product
wordpress: all recordsOther highest-scoring records for the same primary product.
- CVE-2026-87902An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the KEV91Now
- CVE-2026-63030WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code ExecutionKEV72This week
- CVE-2026-119977WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code ExecutionKEV62This week
Published before and after this one in the same product
- ← EarlierCVE-2019-16222Sep 11, 2019 · WordPress before 5.2.3 has an issue with URL sanitization in wp_kses_bad_protocol_once in wp-includes/kses.php that can lead to cross-site s25Monitor
- ← EarlierCVE-2019-16223Sep 11, 2019 · WordPress before 5.2.3 allows XSS in post previews by authenticated users.23Monitor
- Later →CVE-2019-17670Oct 17, 2019 · WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation40Plan
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:wordpress | 5.2.4+dfsg1-1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
The product’s vendor appears in a public program. Matched by name; verify the scope text in the program.
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- No user action is required.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-918 · Server-Side Request Forgery (SSRF)CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Attack patterns (CAPEC)
ATT&CK techniques
—
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (8 more)Show less
- core.trac.wordpress.org/changeset/46475
- github.com/WordPress/WordPress/commit/608d39faed63ea212b6c6cdf9fe2bef92e2120ea
- lists.debian.org/debian-lts-announce/2019/11/msg00000.html
- seclists.org/bugtraq/2020/Jan/8
- wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- wpvulndb.com/vulnerabilities/9912
- www.debian.org/security/2020/dsa-4599
- www.debian.org/security/2020/dsa-4677
Vendor advisories and official records. Exploit/PoC links are deliberately left out.