CVE-2017-1000479: pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrar
Noroxi assessment
Priority: This week (action score 60/100)
- A ready-made attack module is public (Metasploit); exploiting it takes no special expertise.
- A ready-made attack tool exists and the flaw can be exploited over the network without an account, so priority is at least “This week”.
- Probability of exploitation in the next 30 days: 31.7% (FIRST EPSS); higher than 98.2% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. No special conditions are required; it is repeatable.
- Fixed version: n/a n/a 2.4.2-RELEASE.
Don’t wait for the next maintenance window. Upgrade to n/a n/a 2.4.2-RELEASE or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.
- Published
- Jan 3, 2018
- Updated
- Jun 16, 2026
- EPSS
- 31.7% · 98th percentile
- CWE
- CWE-352
Report tools
Action score
60
This week
Don’t wait for the next maintenance window.
- CVSS
- 35 / 40 · 8.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 10 / 30 · 31.7%
- Ready-made attack tool
- 15 / 60 · floor: at least 60
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- Weaponized exploit exists
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| netgate | pfsense | cpe:2.3:a:netgate:pfsense |
| opnsense project | opnsense | cpe:2.3:a:opnsense_project:opnsense |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- netgate pfsenseup to 2.4.1 inclusive
- opnsense project opnsensebefore 16.1.16
Same product
netgate: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-27253A command injection vulnerability in the function restore_rrddata() of Netgate pfSense v2.7.0 allows authenticated attackers to execute arbi62This week
- CVE-2023-48123An issue in Netgate pfSense Plus v.23.05.1 and before and pfSense CE v.2.7.0 allows a remote attacker to execute arbitrary code via a crafte55Plan
- CVE-2023-42326An issue in Netgate pfSense v.2.7.0 allows a remote attacker to execute arbitrary code via a crafted request to the interfaces_gif_edit.php 54Plan
Published before and after this one in the same product
- ← EarlierCVE-2015-6510Aug 18, 2015 · Multiple cross-site scripting (XSS) vulnerabilities in pfSense before 2.2.3 allow remote attackers to inject arbitrary web script or HTML vi18Monitor
- ← EarlierCVE-2015-6511Aug 18, 2015 · Cross-site scripting (XSS) vulnerability in pfSense before 2.2.3 allows remote attackers to inject arbitrary web script or HTML via the serv18Monitor
- Later →CVE-2018-16055Sep 26, 2018 · An authenticated command injection vulnerability exists in status_interfaces.php via dhcp_relinquish_lease() in pfSense before 2.4.4 due to 38Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| n/a n/a | 2.4.2-RELEASE · description | Vendor (CNA) |
Exploit status
Weaponized
A ready exploit tool or active in-the-wild use is known for this vulnerability. This should be your top priority.
Evidence
- Metasploit module ×1
Noroxi does not host or link to exploit code. Metasploit module names and Nuclei template ids are shown (names, not code); Exploit-DB entries and PoC repositories are given as counts only.
| Source | Kind | Date |
|---|---|---|
| Metasploit module | exploit/unix/http/pfsense_clickjackingClickjacking Vulnerability In CSRF Error Page pfSenseexploit | 2017-11-21 |
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
- Metasploit-44 d
- Published
- TodayOct 31, 2026+3223 d
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- No special conditions are required; it is repeatable.
If successful
- Confidentiality
- high · data can be read
- Integrity
- high · data or configuration can be modified
- Availability
- high · the service can be disrupted
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- High
- Integrity impact
- High
- Availability impact
- High
Weakness class (CWE)
CWE-352 · Cross-Site Request Forgery (CSRF)CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
nvd-primary
Root cause
State-changing requests rely on the session cookie the browser sends automatically; nothing verifies that the request came from the user’s own page.
The bug in code
The whole CWE-352 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
app.use(session({ cookie: { httpOnly: true } }));
app.post("/account/address", updateAddress);Fixed
app.use(session({ cookie: { httpOnly: true, sameSite: "lax" } }));
app.post("/account/address", csrfProtection, updateAddress);Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (3 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.