CVE-2013-6365: Horde Groupware Web mail 5.1.2 has CSRF with requests to change permissions
Noroxi assessment
Priority: Monitor (action score 21/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 1% (FIRST EPSS); higher than 64.2% of all records.
- Anyone who can reach it over the internet can trigger it. No account or password is required. A user must open a link or visit a page. Special conditions such as timing or configuration are required.
- Fixed version: php-horde (Debian:12) 5.1.5+debian0-1; php-horde-kronolith (Debian:12) 4.1.4-1.
Low priority for now. Upgrade to php-horde (Debian:12) 5.1.5+debian0-1; php-horde-kronolith (Debian:12) 4.1.4-1 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
- Published
- Nov 5, 2019
- Updated
- Jun 16, 2026
- EPSS
- 1.0% · 64th percentile
- CWE
- CWE-352
Report tools
Action score
21
Monitor
Low priority for now.
- CVSS
- 21 / 40 · 5.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 0 / 30 · 1.0%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| horde | groupware | cpe:2.3:a:horde:groupware |
| opensuse | opensuse | cpe:2.3:o:opensuse:opensuse |
| debian | debian linux | cpe:2.3:o:debian:debian_linux |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- debian debian linux10.0
- debian debian linux8.0
- debian debian linux9.0
- horde groupware5.1.2
- opensuse opensuse13.1
- opensuse opensuse13.2
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | php-horde | before 5.1.5+debian0-1 | 5.1.5+debian0-1 |
| Debian:12 | php-horde-kronolith | before 4.1.4-1 | 4.1.4-1 |
Same product
horde: all recordsOther highest-scoring records for the same primary product.
- CVE-2020-8518Horde Groupware Webmail Edition 5.2.22 allows injection of arbitrary PHP code via CSV data, leading to remote code execution.61This week
- CVE-2022-30287Horde Groupware Webmail Edition through 5.2.22 allows a reflection injection attack through which an attacker can instantiate a driver class53Plan
- CVE-2012-0209Horde 3.3.12, Horde Groupware 1.2.10, and Horde Groupware Webmail Edition 1.2.10, as distributed by FTP between November 2011 and February 252Plan
Published before and after this one in the same product
- ← EarlierCVE-2019-12095Oct 24, 2019 · Horde Trean, as used in Horde Groupware Webmail Edition through 5.2.22 and other products, allows CSRF, as demonstrated by the treanBookmark35Monitor
- ← EarlierCVE-2013-6364Nov 5, 2019 · Horde Groupware Webmail Edition has CSRF and XSS when saving search as a virtual address book36Monitor
- Later →CVE-2013-6275Nov 5, 2019 · Multiple CSRF issues in Horde Groupware Webmail Edition 5.1.2 and earlier in basic.php.27Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:php-horde | 5.1.5+debian0-1 · Debian:12 | Package registry (OSV) |
| debian:php-horde-kronolith | 4.1.4-1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
- Anyone who can reach it over the internet can trigger it.
- No account or password is required.
- A user must open a link or visit a page.
- Special conditions such as timing or configuration are required.
If successful
- Confidentiality
- none
- Integrity
- high · data or configuration can be modified
- Availability
- none
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality impact
- None
- Integrity impact
- High
- Availability impact
- None
Weakness class (CWE)
CWE-352 · Cross-Site Request Forgery (CSRF)CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
nvd-primary
Root cause
State-changing requests rely on the session cookie the browser sends automatically; nothing verifies that the request came from the user’s own page.
The bug in code
The whole CWE-352 classA representative example of this vulnerability class. Not the vendor's source code; it shows the faulty pattern and its fix.
Vulnerable
app.use(session({ cookie: { httpOnly: true } }));
app.post("/account/address", updateAddress);Fixed
app.use(session({ cookie: { httpOnly: true, sameSite: "lax" } }));
app.post("/account/address", csrfProtection, updateAddress);Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (3 more)Show less
Vendor advisories and official records. Exploit/PoC links are deliberately left out.