CVE-2009-1721: The decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a
Noroxi assessment
Priority: Monitor (action score 28/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 4.2% (FIRST EPSS); higher than 91.1% of all records.
- Fixed version: openexr (Debian:12) 1.6.1-4.1; openexr (Debian:4.0) 1.2.2-4.3+etch2; openexr (Debian:5.0) 1.6.1-3+lenny3.
Low priority for now. Upgrade to openexr (Debian:12) 1.6.1-4.1; openexr (Debian:4.0) 1.2.2-4.3+etch2; openexr (Debian:5.0) 1.6.1-3+lenny3 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger a free of an uninitialized pointer.
- Published
- Jul 31, 2009
- Updated
- Jun 16, 2026
- EPSS
- 4.2% · 91th percentile
- CWE
- CWE-824
Report tools
Action score
28
Monitor
Low priority for now.
- CVSS
- 27 / 40 · 6.8 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 1 / 30 · 4.2%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| openexr | openexr | cpe:2.3:a:openexr:openexr |
| opensuse | opensuse | cpe:2.3:o:opensuse:opensuse |
| apple | mac os x | cpe:2.3:o:apple:mac_os_x |
| debian | debian linux | cpe:2.3:o:debian:debian_linux |
| canonical | ubuntu linux | cpe:2.3:o:canonical:ubuntu_linux |
| fedoraproject | fedora | cpe:2.3:o:fedoraproject:fedora |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- apple mac os xbefore 10.5.8
- canonical ubuntu linux8.04
- canonical ubuntu linux8.10
- canonical ubuntu linux9.04
- debian debian linux4.0
- debian debian linux5.0
- fedoraproject fedora10
- fedoraproject fedora11
- openexr openexr1.2.2
- openexr openexr1.6.1
- opensuse opensuse10.0
- opensuse opensuse10.3
- opensuse opensuse11.0
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | openexr | before 1.6.1-4.1 | 1.6.1-4.1 |
| Debian:4.0 | openexr | before 1.2.2-4.3+etch2 | 1.2.2-4.3+etch2 |
| Debian:5.0 | openexr | before 1.6.1-3+lenny3 | 1.6.1-3+lenny3 |
Same product
openexr: all recordsOther highest-scoring records for the same primary product.
- CVE-2023-5841OpenEXR Heap Overflow in Scanline Deep Data Parsing36Monitor
- CVE-2021-23169A heap-buffer overflow was found in the copyIntoFrameBuffer function of OpenEXR in versions before 3.0.1.36Monitor
- CVE-2017-9115In OpenEXR 2.2.0, an invalid write of size 2 in the = operator function in half.h could cause the application to crash or execute arbitrary 36Monitor
Published before and after this one in the same product
- ← EarlierCVE-2009-1720Jul 31, 2009 · Multiple integer overflows in OpenEXR 1.2.2 and 1.6.1 allow context-dependent attackers to cause a denial of service (application crash) or 32Monitor
- Later →CVE-2009-1722Jul 31, 2009 · Heap-based buffer overflow in the compression implementation in OpenEXR 1.2.2 allows context-dependent attackers to cause a denial of servic28Monitor
- Later →CVE-2017-9110May 21, 2017 · In OpenEXR 2.2.0, an invalid read of size 2 in the hufDecode function in ImfHuf.cpp could cause the application to crash.27Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:openexr | 1.6.1-4.1 · Debian:12 | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
No history yet (it accumulates with the daily EPSS job).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
If successful
- Confidentiality
- P · data can be read
- Integrity
- P · data or configuration can be modified
- Availability
- P · the service can be disrupted
- Attack complexity
- M
- Confidentiality impact
- P
- Integrity impact
- P
- Availability impact
- P
Weakness class (CWE)
CWE-824 · Access of Uninitialized PointerCVSS vector
AV:N/AC:M/Au:N/C:P/I:P/A:P
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (19 more)Show less
- lists.opensuse.org/opensuse-security-announce/2009-09/msg00000.html
- release.debian.org/proposed-updates/stable_diffs/openexr_1.6.1-3%2Blenny3.debdiff
- secunia.com/advisories/36030
- secunia.com/advisories/36032
- secunia.com/advisories/36096
- secunia.com/advisories/36123
- secunia.com/advisories/36753
- security.debian.org/pool/updates/main/o/openexr/openexr_1.2.2-4.3+etch2.diff.gz
- security.debian.org/pool/updates/main/o/openexr/openexr_1.6.1-3+lenny3.diff.gz
- support.apple.com/kb/HT3757
- www.debian.org/security/2009/dsa-1842
- www.mandriva.com/security/advisories?name=MDVSA-2009:190
- www.mandriva.com/security/advisories?name=MDVSA-2009:191
- www.securityfocus.com/bid/35838
- www.securitytracker.com/id?1022674
- www.ubuntu.com/usn/USN-831-1
- www.us-cert.gov/cas/techalerts/TA09-218A.html
- www.vupen.com/english/advisories/2009/2035
- www.vupen.com/english/advisories/2009/2172
Vendor advisories and official records. Exploit/PoC links are deliberately left out.