CVE-2006-6143: The RPC library in Kerberos 5 1.4 through 1.4.4, and 1.5 through 1.5.1, as used in Kerberos administration daemon (kadmind) and other produc
Noroxi assessment
Priority: Monitor (action score 39/100)
- The sources we track (CISA KEV, Exploit-DB, Metasploit, Nuclei, GitHub) show no public exploit code or exploitation in the wild.
- Probability of exploitation in the next 30 days: 8.1% (FIRST EPSS); higher than 94.8% of all records.
- Fixed version: krb5 (Debian:12) 1.4.4-6; krb5 (openSUSE:Tumbleweed) 1.19.2-2.2.
Low priority for now. Upgrade to krb5 (Debian:12) 1.4.4-6; krb5 (openSUSE:Tumbleweed) 1.19.2-2.2 or later.
Generated automatically from the record's data: CVSS (NVD and CNA), CISA KEV and SSVC, FIRST EPSS, exploit sources, fixed versions. How we calculate it
Primary sources: NVD · CVE.org · FIRST EPSS
The RPC library in Kerberos 5 1.4 through 1.4.4, and 1.5 through 1.5.1, as used in Kerberos administration daemon (kadmind) and other products that use this library, calls an uninitialized function pointer in freed memory, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
- Published
- Dec 31, 2006
- Updated
- Jun 16, 2026
- EPSS
- 8.1% · 94th percentile
- CWE
- CWE-824
Report tools
Action score
39
Monitor
Low priority for now.
- CVSS
- 37 / 40 · 9.3 / 10
- CISA KEV
- 0 / 30 · Not listed
- EPSS
- 2 / 30 · 8.1%
Get told when this record changes
- Not in KEV: no record of exploitation in the wild
- No public exploit code on record
- A fix has been released
If any of these changes, we'll tell you in the daily email digest.
Running WordPress? Scan your site free with WP Lens
Noroxi analysis
What does it mean in your environment?
The assessment above is generated automatically from the record's data; it doesn't know your environment. Our team verifies on your systems whether this vulnerability is actually exploitable and which mitigation is enough.
We use this product, ask for helpAffected systems
Is your version affected?
Pick the product and type the version you run. It's compared with this record's version ranges in your browser; the version isn't sent anywhere.
| Vendor | Product | CPE |
|---|---|---|
| mit | kerberos 5 | cpe:2.3:a:mit:kerberos_5 |
| canonical | ubuntu linux | cpe:2.3:o:canonical:ubuntu_linux |
Affected versions
NVD version ranges (for catalog products). Add the product to your stack with a version and matching uses these.
- canonical ubuntu linux6.06
- canonical ubuntu linux6.10
- mit kerberos 51.4
- mit kerberos 51.4.1
- mit kerberos 51.4.2
- mit kerberos 51.4.3
- mit kerberos 51.4.4
- mit kerberos 51.5
- mit kerberos 51.5.1
Package-level exposure
OSV and GitHub Advisory data: ecosystem, package and range. SBOM matching uses this table.
| Ecosystem | Package | Affected range | Fix |
|---|---|---|---|
| Debian:12 | krb5 | before 1.4.4-6 | 1.4.4-6 |
| openSUSE:Tumbleweed | krb5 | before 1.19.2-2.2 | 1.19.2-2.2 |
Same product
mit: all recordsOther highest-scoring records for the same primary product.
- CVE-2007-0956The telnet daemon (telnetd) in MIT krb5 before 1.6.1 allows remote attackers to bypass authentication and gain system access via a username 49Plan
- CVE-2011-0285The process_chpw_request function in schpw.c in the password-changing functionality in kadmind in MIT Kerberos 5 (aka krb5) 1.7 through 1.9 46Plan
- CVE-2001-0247Buffer overflows in BSD-based FTP servers allows remote attackers to execute arbitrary commands via a long pattern string containing a {} se46Plan
Published before and after this one in the same product
- ← EarlierCVE-2005-1689Jul 18, 2005 · Double free vulnerability in the krb5_recvauth function in MIT Kerberos 5 (krb5) 1.4.1 and earlier allows remote attackers to execute arbitr42Plan
- ← EarlierCVE-2006-3083Aug 9, 2006 · The (1) krshd and (2) v4rcp applications in (a) MIT Kerberos 5 (krb5) up to 1.5, and 1.4.x before 1.4.4, when running on Linux and AIX, and 28Monitor
- Later →CVE-2006-6144Dec 31, 2006 · The "mechglue" abstraction interface of the GSS-API library for Kerberos 5 1.5 through 1.5.1, as used in Kerberos administration daemon (kad22Monitor
Remediation
Which version to upgrade to
Fix versions compiled from the vendor, package registries and Microsoft. Verify the vendor's note before upgrading.
| Product / package | Fixed version | Source |
|---|---|---|
| debian:krb5 | 1.4.4-6 · Debian:12 | Package registry (OSV) |
| opensuse:krb5 | 1.19.2-2.2 · openSUSE:Tumbleweed | Package registry (OSV) |
Exploit status
No known public exploit
No public exploit has been observed yet. That doesn't mean you're safe, only that the bar is a little higher.
Research context
For pentesters and researchers: attack profile, score disagreement, timeline, patch commits, credits, variant and chain candidates, bug bounty scope. All derived from existing data; no exploit code.
Timeline
From publication to today: proof of concept, Metasploit module, CISA KEV and fix record. Dates are as reported by the sources.
No dated events beyond publication.
FIRST EPSS daily score; only changes of 0.01 or more are recorded (step chart).
Patch and commit links
Commit, PR and diff links among the references. A starting point for patch-diffing and variant hunting; fixes, not exploits.
No commit or PR link among the references.
Credits
All researchersFinders, reporters and analysts named in the CNA record. Click a name for that researcher’s other records.
No credits in the CNA record.
Variant candidates
Same product, same weakness class, within 18 months. If the patch missed the root cause, the sibling bug is here.
No nightly-computed relations.
Chain candidates
An authentication bypass and a privilege-requiring bug in the same product, published close together: combined they may become an unauthenticated path.
—
Bug bounty scope
No known public program.
Source: bounty-targets-data (public HackerOne, Bugcrowd, Intigriti, YesWeHack listings).
Technical details
Attack conditions
If successful
- Confidentiality
- C · data can be read
- Integrity
- C · data or configuration can be modified
- Availability
- C · the service can be disrupted
- Attack complexity
- M
- Confidentiality impact
- C
- Integrity impact
- C
- Availability impact
- C
Weakness class (CWE)
CWE-824 · Access of Uninitialized PointerCVSS vector
AV:N/AC:M/Au:N/C:C/I:C/A:C
nvd-primary
Attack context
MITRE CAPEC attack patterns and ATT&CK techniques for this weakness class (CWE). A starting point for detection rules and threat hunting.
MITRE has no CAPEC/ATT&CK mapping for this CWE.
Change log
- Fix✗ → ✓
For records you follow, these changes also arrive as notifications. →
References
Show all references (19 more)Show less
- fedoranews.org/cms/node/2375
- fedoranews.org/cms/node/2376
- lists.apple.com/archives/Security-announce/2007/Apr/msg00001.html
- lists.suse.com/archive/suse-security-announce/2007-Jan/0004.html
- osvdb.org/31281
- secunia.com/advisories/23667
- secunia.com/advisories/23696
- secunia.com/advisories/23701
- secunia.com/advisories/23706
- secunia.com/advisories/23707
- secunia.com/advisories/23772
- secunia.com/advisories/23903
- secunia.com/advisories/24966
- security.gentoo.org/glsa/glsa-200701-21.xml
- securitytracker.com/id?1017493
- web.mit.edu/kerberos/www/advisories/MITKRB5-SA-2006-002-rpc.txt
- www.kb.cert.org/vuls/id/481564
- www.mandriva.com/security/advisories?name=MDKSA-2007:008
- www.openpkg.com/security/advisories/OpenPKG-SA-2007.006.html
Vendor advisories and official records. Exploit/PoC links are deliberately left out.